summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-04-08 10:49:58 +0200
committerJeroen Roovers <jer@gentoo.org>2017-04-08 10:49:58 +0200
commitc2eb07e857fbd9518a700102af769933d1929dc9 (patch)
treea574602dab0b78fedcef85ff48d503560d679cb0 /dev-libs
parentnet-misc/geoipupdate: Stable for HPPA (bug #611284). (diff)
downloadgentoo-c2eb07e857fbd9518a700102af769933d1929dc9.tar.gz
gentoo-c2eb07e857fbd9518a700102af769933d1929dc9.tar.bz2
gentoo-c2eb07e857fbd9518a700102af769933d1929dc9.zip
dev-libs/geoip: Old.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/geoip/files/geoipupdate-r5.sh46
-rw-r--r--dev-libs/geoip/geoip-1.6.9.ebuild51
2 files changed, 0 insertions, 97 deletions
diff --git a/dev-libs/geoip/files/geoipupdate-r5.sh b/dev-libs/geoip/files/geoipupdate-r5.sh
deleted file mode 100644
index 484ff7e2227a..000000000000
--- a/dev-libs/geoip/files/geoipupdate-r5.sh
+++ /dev/null
@@ -1,46 +0,0 @@
-#!/bin/sh
-
-GEOIP_MIRROR="https://geolite.maxmind.com/download/geoip/database"
-GEOIPDIR=@PREFIX@/usr/share/GeoIP
-TMPDIR=
-
-DATABASES="
- GeoIPv6
- GeoLiteCity
- GeoLiteCityv6-beta/GeoLiteCityv6
- GeoLiteCountry/GeoIP
- asnum/GeoIPASNum
- asnum/GeoIPASNumv6
-"
-
-if [ "${1}" = -f ] || [ "${1}" = --force ]; then
- force=true
-fi
-
-if [ -d "${GEOIPDIR}" ]; then
- cd $GEOIPDIR
- if [ -n "${DATABASES}" ]; then
- TMPDIR=$(mktemp -d geoipupdate.XXXXXXXXXX)
-
- echo "Updating GeoIP databases..."
-
- for db in $DATABASES; do
- fname=$(basename $db)
-
- if [ -f "${GEOIPDIR}/${fname}.dat" ] || [ ${force} ]; then
- wget --no-verbose -t 3 -T 60 \
- "${GEOIP_MIRROR}/${db}.dat.gz" \
- -O "${TMPDIR}/${fname}.dat.gz"
- if [ $? -eq 0 ]; then
- gunzip -fdc "${TMPDIR}/${fname}.dat.gz" > "${TMPDIR}/${fname}.dat"
- mv "${TMPDIR}/${fname}.dat" "${GEOIPDIR}/${fname}.dat"
- chmod 0644 "${GEOIPDIR}/${fname}.dat"
- case ${fname} in
- GeoLite*) ln -sf ${fname}.dat `echo ${fname} | sed 's/GeoLite/GeoIP/'`.dat ;;
- esac
- fi
- fi
- done
- [ -d "${TMPDIR}" ] && rm -rf $TMPDIR
- fi
-fi
diff --git a/dev-libs/geoip/geoip-1.6.9.ebuild b/dev-libs/geoip/geoip-1.6.9.ebuild
deleted file mode 100644
index bee59ac4f113..000000000000
--- a/dev-libs/geoip/geoip-1.6.9.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit autotools eutils
-
-DESCRIPTION="GeoIP Legacy C API"
-HOMEPAGE="https://github.com/maxmind/geoip-api-c"
-SRC_URI="
- https://github.com/maxmind/${PN}-api-c/archive/v${PV}.tar.gz -> ${P}.tar.gz
-"
-
-# GPL-2 for md5.c - part of libGeoIPUpdate, MaxMind for GeoLite Country db
-LICENSE="LGPL-2.1 GPL-2 MaxMind2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
-IUSE="static-libs"
-RESTRICT="test"
-
-DEPEND="net-misc/wget"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${PN}-api-c-${PV}"
-
-src_prepare() {
- eautoreconf
-}
-
-src_configure() {
- econf $(use_enable static-libs static)
- sed -e "s|@PREFIX@|${ROOT}|g" "${FILESDIR}"/geoipupdate-r5.sh > geoipupdate.sh || die
-}
-
-src_install() {
- default
-
- dodoc AUTHORS ChangeLog NEWS.md README*
-
- prune_libtool_files
-
- keepdir /usr/share/GeoIP
-
- dosbin geoipupdate.sh
-}
-
-pkg_postinst() {
- ewarn "WARNING: Databases are no longer installed by this ebuild."
- elog "Don't forget to run 'geoipupdate.sh -f' (or geoipupdate from"
- elog "net-misc/geoipupdate) to populate ${ROOT}/usr/share/GeoIP/"
- elog "with geo-located IP address databases."
-}