summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-06-25 10:57:59 +0200
committerPacho Ramos <pacho@gentoo.org>2016-06-25 14:19:25 +0200
commitc56a202e188afd694f0401d3fd29903d86c5f6c4 (patch)
tree55a55b3f589adc6c60de54c384e92e60822018a3 /dev-libs
parentdev-cpp/gtkmm: Version bump (diff)
downloadgentoo-c56a202e188afd694f0401d3fd29903d86c5f6c4.tar.gz
gentoo-c56a202e188afd694f0401d3fd29903d86c5f6c4.tar.bz2
gentoo-c56a202e188afd694f0401d3fd29903d86c5f6c4.zip
dev-libs/atk: Version bump
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/atk/Manifest1
-rw-r--r--dev-libs/atk/atk-2.20.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-libs/atk/Manifest b/dev-libs/atk/Manifest
index 558e5e3e76f9..fe06502da9b9 100644
--- a/dev-libs/atk/Manifest
+++ b/dev-libs/atk/Manifest
@@ -1,2 +1,3 @@
DIST atk-2.16.0.tar.xz 699816 SHA256 095f986060a6a0b22eb15eef84ae9f14a1cf8082488faa6886d94c37438ae562 SHA512 dc8827779d14fe7212733464f8775f67d60ab3027fcd935245d57c5899e8fc8acc6ceb88ee58f7bfbf259b89447868b3c93726ac56f46bf30a722b47b7bbd7da WHIRLPOOL 94ab7594c9e2508e6e2c9b62bfd80ebedf802a38e5bcd9c28b1224deb56d38d551687d0280e5af57b9713dd1fdbac84c58a03638856aab72bd060009188df641
DIST atk-2.18.0.tar.xz 687932 SHA256 ce6c48d77bf951083029d5a396dd552d836fff3c1715d3a7022e917e46d0c92b SHA512 36f88a6f052ec28c4394756b7de3c1f4c021439eba1e4bfde6ecccd87bab1847111f4cc68ed743c762fcc165c4984c03fd09ea4346e49b2d8dad8b5af36189ea WHIRLPOOL 9f6a40535dda422942f635008e022fb38ea6d1683d51a2d4fa7a2cf3ec5a15ef5f45e83f4344994f706d252b5524fdf6512d2a80c45b22be24d62cae1f11a3be
+DIST atk-2.20.0.tar.xz 724200 SHA256 493a50f6c4a025f588d380a551ec277e070b28a82e63ef8e3c06b3ee7c1238f0 SHA512 3dab21e59f47deeee7c4b95dbda1c9a57a15007367af584a27c472e20f11bebd210ae7cd16b255e810f66df4c0a2bee14d904c46e1367ce5a6ade6f5af81bace WHIRLPOOL accada46d8c3b134aabea8dc88d33fb55be317ddc7fbb9bae7746e982df63a8515c530af87aa2310a7bcfee0080583080306cf094332acce7a747f80c6247484
diff --git a/dev-libs/atk/atk-2.20.0.ebuild b/dev-libs/atk/atk-2.20.0.ebuild
new file mode 100644
index 000000000000..a67eb716a389
--- /dev/null
+++ b/dev-libs/atk/atk-2.20.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit gnome2 multilib-minimal
+
+DESCRIPTION="GTK+ & GNOME Accessibility Toolkit"
+HOMEPAGE="https://wiki.gnome.org/Accessibility"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="+introspection nls test"
+
+RDEPEND="
+ >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5
+ dev-util/gtk-doc-am
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+ nls? ( >=sys-devel/gettext-0.19.2 )
+"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ if ! use test; then
+ # don't waste time building tests (bug #226353)
+ sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
+ || die "sed failed"
+ fi
+
+ # Building out of sources fails, https://bugzilla.gnome.org/show_bug.cgi?id=752507
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+# ECONF_SOURCE=${S} \
+ gnome2_src_configure \
+ $(multilib_native_use_enable introspection)
+
+ # work-around gtk-doc out-of-source brokedness
+# if multilib_is_native_abi; then
+# ln -s "${S}"/docs/html docs/html || die
+# fi
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}