summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-05-21 21:54:28 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-05-22 06:43:31 +0200
commitcdd4faf32dfb7817a73c649f96295a83c89c0b61 (patch)
treebafdafc15653579eed51dc13cc98378507e922ba /dev-libs
parentmedia-sound/pulseeffects: 3.2.3 stable amd64 and x86 (diff)
downloadgentoo-cdd4faf32dfb7817a73c649f96295a83c89c0b61.tar.gz
gentoo-cdd4faf32dfb7817a73c649f96295a83c89c0b61.tar.bz2
gentoo-cdd4faf32dfb7817a73c649f96295a83c89c0b61.zip
dev-libs/libindicate: EAPI-6 bump
Package-Manager: Portage-2.3.38, Repoman-2.3.9
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libindicate/files/libindicate-0.6.1-no-mono.patch8
-rw-r--r--dev-libs/libindicate/libindicate-12.10.1-r3.ebuild75
2 files changed, 79 insertions, 4 deletions
diff --git a/dev-libs/libindicate/files/libindicate-0.6.1-no-mono.patch b/dev-libs/libindicate/files/libindicate-0.6.1-no-mono.patch
index 349828a6058c..1743f861f4ba 100644
--- a/dev-libs/libindicate/files/libindicate-0.6.1-no-mono.patch
+++ b/dev-libs/libindicate/files/libindicate-0.6.1-no-mono.patch
@@ -1,7 +1,7 @@
Temporary patch to disable mono until new gtk-sharp is in tree wrt bug #382491
---- bindings/Makefile.am
-+++ bindings/Makefile.am
+--- a/bindings/Makefile.am
++++ b/bindings/Makefile.am
@@ -1,9 +1,5 @@
SUBDIRS =
@@ -12,8 +12,8 @@ Temporary patch to disable mono until new gtk-sharp is in tree wrt bug #382491
if HAS_PYTHON
SUBDIRS += python
endif
---- configure.ac
-+++ configure.ac
+--- a/configure.ac
++++ b/configure.ac
@@ -124,61 +124,6 @@
AC_PATH_PROG([VALA_API_GEN], [vapigen])
diff --git a/dev-libs/libindicate/libindicate-12.10.1-r3.ebuild b/dev-libs/libindicate/libindicate-12.10.1-r3.ebuild
new file mode 100644
index 000000000000..73526a89128e
--- /dev/null
+++ b/dev-libs/libindicate/libindicate-12.10.1-r3.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VALA_MIN_API_VERSION="0.16"
+VALA_USE_DEPEND="vapigen"
+inherit autotools flag-o-matic vala xdg-utils
+
+DESCRIPTION="Library to raise flags on DBus for other components of the desktop"
+HOMEPAGE="https://launchpad.net/libindicate"
+SRC_URI="https://launchpad.net/${PN}/${PV%.*}/${PV}/+download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1 LGPL-3"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="gtk +introspection"
+
+RESTRICT="test" # consequence of the -no-mono.patch
+
+RDEPEND="
+ dev-libs/dbus-glib
+ dev-libs/glib:2
+ dev-libs/libdbusmenu[introspection?]
+ dev-libs/libxml2
+ gtk? (
+ dev-libs/libdbusmenu[gtk3]
+ x11-libs/gtk+:3
+ )
+ introspection? ( >=dev-libs/gobject-introspection-1 )
+"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ app-text/gnome-doc-utils
+ dev-util/gtk-doc-am
+ gnome-base/gnome-common
+ virtual/pkgconfig
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.6.1-no-mono.patch )
+
+src_prepare() {
+ default
+ xdg_environment_reset
+ vala_src_prepare
+
+ sed -i \
+ -e "s:vapigen:vapigen-$(vala_best_api_version):" \
+ -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" \
+ configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ append-flags -Wno-error
+
+ # python bindings are only for GTK+-2.x
+ econf \
+ --disable-silent-rules \
+ --disable-static \
+ $(use_enable gtk) \
+ $(use_enable introspection) \
+ --disable-python \
+ --disable-scrollkeeper \
+ --with-gtk=3
+}
+
+src_install() {
+ # work around failing parallel installation (-j1)
+ # until a better fix is available. (bug #469032)
+ emake -j1 DESTDIR="${D}" install
+ einstalldocs
+ find "${D}" -name '*.la' -delete || die
+}