summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2021-01-22 10:39:05 -0800
committerPatrick McLean <chutzpah@gentoo.org>2021-01-22 10:39:05 -0800
commitd03bbbe108ea2d44a44d41e104c015686d24094c (patch)
tree893403bcbcc62358251ff5f3c7eba12f627ca2db /dev-libs
parentdev-util/chroot-wrapper-0.9.4: Version bump (diff)
downloadgentoo-d03bbbe108ea2d44a44d41e104c015686d24094c.tar.gz
gentoo-d03bbbe108ea2d44a44d41e104c015686d24094c.tar.bz2
gentoo-d03bbbe108ea2d44a44d41e104c015686d24094c.zip
dev-libs/simdjson-0.8.0: Version bump
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/simdjson/Manifest1
-rw-r--r--dev-libs/simdjson/files/simdjson-0.8.0-dont-bundle-cxxopts.patch40
-rw-r--r--dev-libs/simdjson/simdjson-0.8.0.ebuild67
3 files changed, 108 insertions, 0 deletions
diff --git a/dev-libs/simdjson/Manifest b/dev-libs/simdjson/Manifest
index 18e6617aa5fc..8410ab853252 100644
--- a/dev-libs/simdjson/Manifest
+++ b/dev-libs/simdjson/Manifest
@@ -2,3 +2,4 @@ DIST simdjson-0.4.7.tar.gz 4119328 BLAKE2B f19a603b83282081457f548bd9b609f4fc4b9
DIST simdjson-0.6.0-ppc64.patch.xz 23704 BLAKE2B ab26e93960d3e3cc2c7782516ef2e6e36fb259c1bd83b967f32b0ba899ca9f80468a47cc3344dd9dc392898626a88b4a1de42899502a989511945e573bf7f259 SHA512 c8e1233c7e6f92cf0c92206ae1023cd30067004e4e53fed86d11e105490f281bf1b8a0806880d02427485fbade24aeb7a7b027b17c9f05552089cf867f3029eb
DIST simdjson-0.6.1.tar.gz 7889048 BLAKE2B 35b40e5e278e5093f5f07ad9e27ae23417f206bf2f4f624a6130931882db49632fc5141d027deca4977a3efa1fdfc7d8fc0bc2149d938a985a850eff4250f5bf SHA512 df5f6c717b3c4cfcde7757dff74d51c93f4682729fdbcdaae89d82db13bba006fe0378bc601d5bdf1d4cf2f0fafce56eb88aba8ca9648787a64cf160cab479e4
DIST simdjson-0.7.1.tar.gz 7972319 BLAKE2B c06b1db95b5d826babf7c673b8ef390c2169d975bbec585f6ea98a53455643b4ec462683d312fabbf8a1155309ba9fdd20977ba813e0fbfad5cbe45363ef7189 SHA512 f2ed21db24a8c80c48194e875680ee27dcb87ce1ee52d7f7466e3096661ccee179986bdc15d93e2a3d8d9f2f659f3bd678c908cfbde4905afd95e5e767f84e1c
+DIST simdjson-0.8.0.tar.gz 7993692 BLAKE2B f2f04b3f9815645fcb4fcf2d10b0a234177042a0f4e306b0e130d5136c627344201a1f7c4d1ba6cb1ce30debf44f00694bc9a5bb646040bb614e91ae31bf43bb SHA512 8c41e07dbc3668105131c5a22060891c54f7663ec512d6c12f18eed0971fe245c3adb8d27c27305827314ebff39d2c940bd3715fa12e1ce9332d9bf3693424f2
diff --git a/dev-libs/simdjson/files/simdjson-0.8.0-dont-bundle-cxxopts.patch b/dev-libs/simdjson/files/simdjson-0.8.0-dont-bundle-cxxopts.patch
new file mode 100644
index 000000000000..6a76cf83ed98
--- /dev/null
+++ b/dev-libs/simdjson/files/simdjson-0.8.0-dont-bundle-cxxopts.patch
@@ -0,0 +1,40 @@
+diff --git a/dependencies/CMakeLists.txt b/dependencies/CMakeLists.txt
+index 2c41169f..2f5d4436 100644
+--- a/dependencies/CMakeLists.txt
++++ b/dependencies/CMakeLists.txt
+@@ -129,15 +129,3 @@ endfunction()
+ if(SIMDJSON_COMPETITION)
+ competition_scope_()
+ endif()
+-
+-cmake_dependent_option(SIMDJSON_CXXOPTS "Download cxxopts (necessary for tools)" ON
+- SIMDJSON_ALLOW_DOWNLOADS OFF)
+-
+-if(SIMDJSON_CXXOPTS)
+- set_off(CXXOPTS_BUILD_EXAMPLES)
+- set_off(CXXOPTS_BUILD_TESTS)
+- set_off(CXXOPTS_ENABLE_INSTALL)
+-
+- import_dependency(cxxopts jarro2783/cxxopts 794c975)
+- add_dependency(cxxopts)
+-endif()
+diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
+index f1a82be7..b1b7b1a0 100644
+--- a/tools/CMakeLists.txt
++++ b/tools/CMakeLists.txt
+@@ -1,10 +1,8 @@
+-if(TARGET cxxopts) # we only build the tools if cxxopts is available
+ message(STATUS "We have cxxopts as a dependency and we are buiding the tools (e.g., json2json).")
+- link_libraries(simdjson simdjson-internal-flags simdjson-windows-headers cxxopts)
++ link_libraries(simdjson simdjson-internal-flags simdjson-windows-headers)
+ add_executable(json2json json2json.cpp)
+ add_executable(jsonstats jsonstats.cpp)
+- add_executable(jsonpointer jsonpointer.cpp)
++ add_executable(simdjsonpointer jsonpointer.cpp)
+ add_executable(minify minify.cpp)
+-else()
+- message(STATUS "We are missing cxxopts as a dependency so the tools (e.g., json2json) are omitted.")
+-endif()
+\ No newline at end of file
++ install(TARGETS json2json jsonstats simdjsonpointer minify DESTINATION bin)
++
diff --git a/dev-libs/simdjson/simdjson-0.8.0.ebuild b/dev-libs/simdjson/simdjson-0.8.0.ebuild
new file mode 100644
index 000000000000..b97cc2e514e7
--- /dev/null
+++ b/dev-libs/simdjson/simdjson-0.8.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs cmake
+
+DESCRIPTION="SIMD accelerated C++ JSON library"
+HOMEPAGE="
+ https://simdjson.org/
+ https://github.com/simdjson/simdjson
+"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 Boost-1.0"
+SLOT="0/4"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="test tools"
+
+BDEPEND="
+ sys-apps/file
+ sys-apps/findutils
+ sys-apps/grep
+"
+DEPEND="
+ tools? ( dev-libs/cxxopts:= )
+"
+
+REQUIRED_USE="test? ( tools )"
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}/simdjson-0.8.0-dont-bundle-cxxopts.patch"
+)
+
+DOCS=(
+ AUTHORS
+ CONTRIBUTING.md
+ CONTRIBUTORS
+ HACKING.md
+ README.md
+)
+
+src_prepare() {
+ sed -e 's:-Werror ::' -i cmake/simdjson-flags.cmake || die
+ cmake_src_prepare
+}
+
+src_configure() {
+ local -a mycmakeargs=(
+ -DSIMDJSON_ENABLE_THREADS=ON
+ )
+
+ if use tools; then
+ mycmakeargs+=(
+ -DSIMDJSON_JUST_LIBRARY=OFF
+ -DSIMDJSON_GOOGLE_BENCHMARKS=OFF
+ -DSIMDJSON_COMPETITION=OFF
+ )
+ else
+ mycmakeargs+=(
+ -DSIMDJSON_JUST_LIBRARY=ON
+ )
+ fi
+
+ cmake_src_configure
+}