summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-03-30 10:06:19 +0200
committerLars Wendler <polynomial-c@gentoo.org>2021-03-30 10:06:52 +0200
commitde1d381ac3aa9f001125f3b290a35afdbda0e6e4 (patch)
treea08b1b47d17b024da3ff795735ddc323f71890d1 /dev-libs
parentwww-client/seamonkey: Bump to version 2.53.7. Removed old. (diff)
downloadgentoo-de1d381ac3aa9f001125f3b290a35afdbda0e6e4.tar.gz
gentoo-de1d381ac3aa9f001125f3b290a35afdbda0e6e4.tar.bz2
gentoo-de1d381ac3aa9f001125f3b290a35afdbda0e6e4.zip
dev-libs/libfido2: Bump to version 1.7.0
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libfido2/Manifest1
-rw-r--r--dev-libs/libfido2/files/libfido2-1.7.0-cmakelists.patch30
-rw-r--r--dev-libs/libfido2/libfido2-1.7.0.ebuild57
-rw-r--r--dev-libs/libfido2/metadata.xml3
4 files changed, 91 insertions, 0 deletions
diff --git a/dev-libs/libfido2/Manifest b/dev-libs/libfido2/Manifest
index 364924cc4acf..0436533ab99d 100644
--- a/dev-libs/libfido2/Manifest
+++ b/dev-libs/libfido2/Manifest
@@ -1,2 +1,3 @@
DIST libfido2-1.5.0.tar.gz 407259 BLAKE2B 23a04f9230c45652aa1ac9fd8b3e809096ae31699c65ca0fda27b27b1b47263e375bb99e5b1ebc515b9edfb801bb2fba9c4f50d88e755efe3eaa23463ca01946 SHA512 240e2368e43846fddf5e98bbcc247468833565bcde4ec27976b88c814d787f1a477241a82b064818aa0eb0a98ff46a65d80b8243f4d0bbd763270e42492354e2
DIST libfido2-1.6.0.tar.gz 413904 BLAKE2B 59444cc9e32b5d9f2a0f9138fe4f3ad644865e1f7f24f50bbace262308aa7c10b58aa0e890a3493e8fd102468e26947f7fc0864b5d7a1e185e40ad730064db8e SHA512 c473732a2f7ef54156097d315e44457d89056446ab3112a7c7a6fd99d5c2c8ae0ca2451ff9cd45be6c32de1ab335d6dfdb2b0c56b40cae9eb41391d18d83be4a
+DIST libfido2-1.7.0.tar.gz 517426 BLAKE2B c7ad55d1402808ad12dc999b0ec67161a5fe82dfeaeed362c35f4183144af9bd2771c1e3318a731db46fd8fc21ccd0737024b72c8dd3c754e34625118817742f SHA512 f40d394883d909e9e3ea3308b32f7ca31a882c709e11b3b143ed5734d16b0c244d4932effe06965d566776b03d152b1fc280e73cdfeeb81b65d8414042af19fe
diff --git a/dev-libs/libfido2/files/libfido2-1.7.0-cmakelists.patch b/dev-libs/libfido2/files/libfido2-1.7.0-cmakelists.patch
new file mode 100644
index 000000000000..2a1bfc1614db
--- /dev/null
+++ b/dev-libs/libfido2/files/libfido2-1.7.0-cmakelists.patch
@@ -0,0 +1,30 @@
+--- libfido2-1.7.0/CMakeLists.txt
++++ libfido2-1.7.0/CMakeLists.txt
+@@ -246,14 +246,12 @@
+
+ add_compile_options(-Wall)
+ add_compile_options(-Wextra)
+- add_compile_options(-Werror)
+ add_compile_options(-Wshadow)
+ add_compile_options(-Wcast-qual)
+ add_compile_options(-Wwrite-strings)
+ add_compile_options(-Wmissing-prototypes)
+ add_compile_options(-Wbad-function-cast)
+ add_compile_options(-pedantic)
+- add_compile_options(-pedantic-errors)
+
+ if(HAVE_SHORTEN_64_TO_32)
+ add_compile_options(-Wshorten-64-to-32)
+--- libfido2-1.7.0/man/CMakeLists.txt
++++ libfido2-1.7.0/man/CMakeLists.txt
+@@ -3,10 +3,8 @@
+ # license that can be found in the LICENSE file.
+
+ find_program(MANDOC_PATH mandoc)
+-find_program(GZIP_PATH gzip)
+
+ message(STATUS "MANDOC_PATH: ${MANDOC_PATH}")
+-message(STATUS "GZIP_PATH: ${GZIP_PATH}")
+
+ list(APPEND MAN_SOURCES
+ eddsa_pk_new.3
diff --git a/dev-libs/libfido2/libfido2-1.7.0.ebuild b/dev-libs/libfido2/libfido2-1.7.0.ebuild
new file mode 100644
index 000000000000..21c57df89552
--- /dev/null
+++ b/dev-libs/libfido2/libfido2-1.7.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake udev linux-info
+
+DESCRIPTION="Provides library functionality for FIDO 2.0"
+HOMEPAGE="https://github.com/Yubico/libfido2"
+SRC_URI="https://github.com/Yubico/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="nfc +static-libs"
+
+DEPEND="
+ dev-libs/libcbor:=
+ dev-libs/openssl:0=
+ sys-libs/zlib:0=
+ virtual/libudev:=
+"
+
+RDEPEND="
+ ${DEPEND}
+ acct-group/plugdev
+"
+
+PATCHES=(
+ "${FILESDIR}/libfido2-1.7.0-cmakelists.patch"
+)
+
+pkg_pretend() {
+ CONFIG_CHECK="
+ ~USB_HID
+ ~HIDRAW
+ "
+
+ check_extra_config
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DNFC_LINUX="$(usex nfc)"
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ if ! use static-libs; then
+ rm -f "${ED}/$(get_libdir)"/*.a || die
+ fi
+
+ udev_newrules udev/70-u2f.rules 70-libfido2-u2f.rules
+}
diff --git a/dev-libs/libfido2/metadata.xml b/dev-libs/libfido2/metadata.xml
index 4eb20a048df2..faf987beddfa 100644
--- a/dev-libs/libfido2/metadata.xml
+++ b/dev-libs/libfido2/metadata.xml
@@ -5,4 +5,7 @@
<email>base-system@gentoo.org</email>
<name>Gentoo Base System</name>
</maintainer>
+ <use>
+ <flag name="nfc">Enable experimental NFC support</flag>
+ </use>
</pkgmetadata>