summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2016-01-27 18:09:52 +0300
committerSergey Popov <pinkbyte@gentoo.org>2016-01-27 18:10:54 +0300
commite689510744193740b58991b8ba7a8ed82bffc18f (patch)
treef61b71eeb997a0798681fddd96c4d1cc56d07c2d /dev-libs
parentmedia-video/ffmpeg: Stable for HPPA PPC64 (bug #571868). (diff)
downloadgentoo-e689510744193740b58991b8ba7a8ed82bffc18f.tar.gz
gentoo-e689510744193740b58991b8ba7a8ed82bffc18f.tar.bz2
gentoo-e689510744193740b58991b8ba7a8ed82bffc18f.zip
dev-libs/confuse: version bump
Bump EAPI to 6, add multilib support Gentoo-Bug: 569788 Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/confuse/Manifest1
-rw-r--r--dev-libs/confuse/confuse-2.8.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-libs/confuse/Manifest b/dev-libs/confuse/Manifest
index 6e24bbd71065..bc7b87ea8af8 100644
--- a/dev-libs/confuse/Manifest
+++ b/dev-libs/confuse/Manifest
@@ -1 +1,2 @@
DIST confuse-2.7.tar.gz 517272 SHA256 e32574fd837e950778dac7ade40787dd2259ef8e28acd6ede6847ca895c88778 SHA512 c9a9236c4e15928bbf41da5c0d35f85e6f939a5247a37edf3f5b2921d27c9db3773c26f1bcaa8b6433b498c0920cc5d48bd5486dc394e17af112b36f49f95a42 WHIRLPOOL 22e657a1172005bc527951738540103c8ae7dbd61d70cb8dfb3bfc49bc01d102331f1187a4e8b0906161ac2e806a3d5cc781ce69cd5443560fe83b619fe8884e
+DIST confuse-2.8.tar.xz 403252 SHA256 2a8102bfa3ccc846c14d94a81b0abfb4f5e855809f89ff3722aca1a9f314ea0d SHA512 af428936caad9dac0bf052210abeb0fd4b4450114a2a5185db7d995e11cdd0e52cb0148bb46228d26e38a4b50a2810f6e4b282502f0e34c617bf4368795a9d79 WHIRLPOOL ee647ffabebb05641aa49a4294b7a9dc2aad9503fefab537244618baf0556b1e7cb58b006d5f95cfefbe3967442845e61f407ca38561c2aca1dc5fdb9dffa115
diff --git a/dev-libs/confuse/confuse-2.8.ebuild b/dev-libs/confuse/confuse-2.8.ebuild
new file mode 100644
index 000000000000..c870b06e0fb3
--- /dev/null
+++ b/dev-libs/confuse/confuse-2.8.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils multilib-minimal
+
+DESCRIPTION="a configuration file parser library"
+HOMEPAGE="http://www.nongnu.org/confuse/"
+SRC_URI="https://github.com/martinh/libconfuse/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+
+IUSE="nls static-libs"
+
+DEPEND="sys-devel/flex
+ sys-devel/libtool
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+RDEPEND="nls? ( virtual/libintl[${MULTILIB_USEDEP}] )"
+
+DOCS=( AUTHORS )
+
+src_prepare() {
+ rm doc/man/man3/_* || die
+
+ eapply_user
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ # examples are normally compiled but not installed. They
+ # fail during a mingw crosscompile.
+ local ECONF_SOURCE=${BUILD_DIR}
+ econf \
+ --enable-shared \
+ --disable-examples \
+ $(use_enable nls) \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ prune_libtool_files
+
+ doman doc/man/man3/*.3
+ dodoc -r doc/html
+
+ docinto examples
+ dodoc examples/*.{c,conf}
+}