summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2021-01-20 13:26:42 +0800
committerBenda Xu <heroxbd@gentoo.org>2021-01-20 13:26:42 +0800
commitfcb201320292ec4d5b9015425a3069c2fb6835bb (patch)
treec5b9c5578c4e1259545f4604d194751f1f7f58e4 /dev-libs
parentdev-libs/rocclr: support Prefix. (diff)
downloadgentoo-fcb201320292ec4d5b9015425a3069c2fb6835bb.tar.gz
gentoo-fcb201320292ec4d5b9015425a3069c2fb6835bb.tar.bz2
gentoo-fcb201320292ec4d5b9015425a3069c2fb6835bb.zip
dev-libs/rocm-opencl-runtime: support Prefix.
Drop an upstream fixed hack. Reference: https://github.com/RadeonOpenCompute/ROCm-OpenCL-Runtime/commit/2bfbd8a80d3cdb5d4ead23301c12bf719c47b790 Suggested-by: Suggested-by: Yiyang Wu <xgreenlandforwyy@gmail.com> Package-Manager: Portage-3.0.12, Repoman-3.0.1 Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-4.0.0.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-4.0.0.ebuild b/dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-4.0.0.ebuild
index 125321094992..d3a5d3f5ef89 100644
--- a/dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-4.0.0.ebuild
+++ b/dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-4.0.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake flag-o-matic
+inherit cmake flag-o-matic prefix
if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/RadeonOpenCompute/ROCm-OpenCL-Runtime/"
@@ -42,10 +42,9 @@ src_prepare() {
# Remove "clinfo" - use "dev-util/clinfo" instead
[ -d tools/clinfo ] && rm -rf tools/clinfo || die
- # Wrong position of a '"' results in a list of strings instead of a single string and the build fails...
- sed -e "s:set(CMAKE_SHARED_LINKER_FLAGS \${CMAKE_SHARED_LINKER_FLAGS} \":set(CMAKE_SHARED_LINKER_FLAGS \"\${CMAKE_SHARED_LINKER_FLAGS} :" -i "${S}/amdocl/CMakeLists.txt"
-
cmake_src_prepare
+
+ hprefixify amdocl/CMakeLists.txt
}
src_configure() {