summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarald Judt <h.judt@gmx.at>2020-06-05 00:39:28 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-06-24 19:29:37 +0300
commitfa0cbe2e00fc7c43ff5fceee213b89254f54cdc1 (patch)
tree8b86031ad8104be8a1f70bb7da297423d08a247a /dev-lisp/c2ffi/c2ffi-10.0.0.20200527.ebuild
parentsys-apps/fwts: cosmetic updates for 20.05.00 (diff)
downloadgentoo-fa0cbe2e00fc7c43ff5fceee213b89254f54cdc1.tar.gz
gentoo-fa0cbe2e00fc7c43ff5fceee213b89254f54cdc1.tar.bz2
gentoo-fa0cbe2e00fc7c43ff5fceee213b89254f54cdc1.zip
dev-lisp/c2ffi: Bump version to c2ffi-10.0.0
Update to c2ffi-10, using clang-10. This time, it was only necessary to add a target_link_directories directive to CMakeLists.txt. Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Harald Judt <h.judt@gmx.at> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-lisp/c2ffi/c2ffi-10.0.0.20200527.ebuild')
-rw-r--r--dev-lisp/c2ffi/c2ffi-10.0.0.20200527.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-lisp/c2ffi/c2ffi-10.0.0.20200527.ebuild b/dev-lisp/c2ffi/c2ffi-10.0.0.20200527.ebuild
new file mode 100644
index 000000000000..56aaeae61858
--- /dev/null
+++ b/dev-lisp/c2ffi/c2ffi-10.0.0.20200527.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake llvm
+
+MY_COMMIT="a2d1f667b707fb413fc8ab2413446f15cb23de51"
+
+DESCRIPTION="Clang-based FFI wrapper generator for Common Lisp"
+HOMEPAGE="https://github.com/rpav/c2ffi"
+SRC_URI="https://github.com/rpav/c2ffi/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="sys-devel/clang:10=
+ sys-devel/llvm:10=
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/c2ffi-${MY_COMMIT}"
+
+PATCHES=( "${FILESDIR}"/${PN}-10.0.0.20200527-add-target-link-directories.patch )