summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-lisp/cl-clx
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-lisp/cl-clx')
-rw-r--r--dev-lisp/cl-clx/Manifest3
-rw-r--r--dev-lisp/cl-clx/cl-clx-0.7.1.ebuild34
-rw-r--r--dev-lisp/cl-clx/cl-clx-0.7.2.ebuild34
-rw-r--r--dev-lisp/cl-clx/cl-clx-0.7.3.ebuild41
-rw-r--r--dev-lisp/cl-clx/files/0.6.1-gentoo.patch108
-rw-r--r--dev-lisp/cl-clx/metadata.xml19
6 files changed, 239 insertions, 0 deletions
diff --git a/dev-lisp/cl-clx/Manifest b/dev-lisp/cl-clx/Manifest
new file mode 100644
index 000000000000..d6ffd10df415
--- /dev/null
+++ b/dev-lisp/cl-clx/Manifest
@@ -0,0 +1,3 @@
+DIST clx_0.7.1.tar.gz 406363 SHA256 7c6bce234794664def6ad1350b00de470301c975782c0aa73d9a1f1f1288b731 SHA512 bf9dafdf26a6d7a5ffae9b59deed7f2779f472afce4904cbecc812dfb769277daf983aac099911b0ae74fee709cb87d8182137a0e6f93235056a30c56854a137 WHIRLPOOL 803819402f7bc47495eae7d46c00c78353b9d88a04f71e039abf5faa3d8fc18287303f79226626a711a7cb73675fa88e8ed1f256fdff28bd8b5d9d7c29cbff95
+DIST clx_0.7.2.tar.gz 419578 SHA256 d30bd23cb51000c237ef6bb4036d1134507b80b6ce8268a3ae808554ad52b095 SHA512 4c48780294a2e0d43d384450129be801897838142b2762098e71fe950350a41ccbcd8ebe6433d666605e20e5de7acac9681af8630b50c4e67cf24691a90f9859 WHIRLPOOL f876c64c94745fb4dcfd620af16791b5446f3beed6b1c2e677c17d94d88997d2b6f0b20bbf058616da3256757987afe8e4314546e6b6c34cde0acff7d1649745
+DIST clx_0.7.3.tar.gz 438168 SHA256 1f0f79cec7c7c314a4612256b33b8af507493ae4f7e3882b6c7bf5fb8e6f0c7b SHA512 b60e6cb0393e658d1a42957e2ba36bbaee5357979247ec2aaa25c105b2f83962c48594de5df5a7269c6289ff383697c9180ae243031757891b0233c2c2df5a6e WHIRLPOOL 036235e8dc80b3a4e97da3cc36008d9dff79b5dd74fe2797d2dfe33b5c53cea82a616007cc29e4194177713f75e611a9d581e46bc0092db83336d1ba1984e259
diff --git a/dev-lisp/cl-clx/cl-clx-0.7.1.ebuild b/dev-lisp/cl-clx/cl-clx-0.7.1.ebuild
new file mode 100644
index 000000000000..0216f25dbfc3
--- /dev/null
+++ b/dev-lisp/cl-clx/cl-clx-0.7.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit common-lisp eutils
+
+DESCRIPTION="Portable CLX"
+HOMEPAGE="http://ftp.linux.org.uk/pub/lisp/sbcl/ http://www.cliki.net/CLX"
+SRC_URI="http://ftp.linux.org.uk/pub/lisp/sbcl/clx_${PV}.tar.gz"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc x86"
+IUSE=""
+
+DEPEND="dev-lisp/common-lisp-controller"
+
+CLPACKAGE=clx
+
+S=${WORKDIR}/clx_${PV}
+
+src_install() {
+ for i in . demo test debug; do
+ insinto /usr/share/common-lisp/source/clx/${i}
+ doins ${S}/${i}/*.lisp
+ done
+ insinto /usr/share/common-lisp/source/clx
+ doins clx.asd NEWS CHANGES README README-R5 \
+ excl* sock*
+ insinto /usr/share/common-lisp/source/manual
+ doins manual/clx.texinfo
+ common-lisp-system-symlink
+ dodoc CHANGES NEWS README*
+}
diff --git a/dev-lisp/cl-clx/cl-clx-0.7.2.ebuild b/dev-lisp/cl-clx/cl-clx-0.7.2.ebuild
new file mode 100644
index 000000000000..955f421c212f
--- /dev/null
+++ b/dev-lisp/cl-clx/cl-clx-0.7.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit common-lisp eutils
+
+DESCRIPTION="Portable CLX"
+HOMEPAGE="http://ftp.linux.org.uk/pub/lisp/sbcl/ http://www.cliki.net/CLX"
+SRC_URI="http://ftp.linux.org.uk/pub/lisp/sbcl/clx_${PV}.tar.gz"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-lisp/common-lisp-controller"
+
+CLPACKAGE=clx
+
+S=${WORKDIR}/clx_${PV}
+
+src_install() {
+ for i in . demo test debug; do
+ insinto /usr/share/common-lisp/source/clx/${i}
+ doins ${S}/${i}/*.lisp
+ done
+ insinto /usr/share/common-lisp/source/clx
+ doins clx.asd NEWS CHANGES README README-R5 \
+ excl* sock*
+ insinto /usr/share/common-lisp/source/manual
+ doins manual/clx.texinfo
+ common-lisp-system-symlink
+ dodoc CHANGES NEWS README*
+}
diff --git a/dev-lisp/cl-clx/cl-clx-0.7.3.ebuild b/dev-lisp/cl-clx/cl-clx-0.7.3.ebuild
new file mode 100644
index 000000000000..a43f826a32af
--- /dev/null
+++ b/dev-lisp/cl-clx/cl-clx-0.7.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit common-lisp eutils
+
+DESCRIPTION="CLX is the Common Lisp interface to the X11 protocol primarily for SBCL"
+HOMEPAGE="http://ftp.linux.org.uk/pub/lisp/sbcl/ http://www.cliki.net/CLX"
+SRC_URI="http://ftp.linux.org.uk/pub/lisp/sbcl/clx_${PV}.tar.gz"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="amd64 ppc ~sparc x86"
+IUSE=""
+
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp
+ sys-apps/texinfo"
+
+CLPACKAGE=clx
+
+S=${WORKDIR}/clx_${PV}
+
+src_compile() {
+ makeinfo manual/clx.texinfo || die
+}
+
+src_install() {
+ for i in . demo test debug; do
+ insinto /usr/share/common-lisp/source/clx/${i}
+ doins "${S}"/${i}/*.lisp
+ done
+ insinto /usr/share/common-lisp/source/clx
+ doins clx.asd NEWS CHANGES README README-R5 \
+ excl* sock*
+ insinto /usr/share/common-lisp/source/manual
+ doins manual/clx.texinfo # part of system definition
+ common-lisp-system-symlink
+ dodoc CHANGES NEWS README*
+ doinfo clx.info*
+}
diff --git a/dev-lisp/cl-clx/files/0.6.1-gentoo.patch b/dev-lisp/cl-clx/files/0.6.1-gentoo.patch
new file mode 100644
index 000000000000..4f3a63ee31c3
--- /dev/null
+++ b/dev-lisp/cl-clx/files/0.6.1-gentoo.patch
@@ -0,0 +1,108 @@
+diff -ur clx_0.6.1.orig/clx.asd clx_0.6.1/clx.asd
+--- clx_0.6.1.orig/clx.asd 2005-03-29 08:42:20.000000000 -0600
++++ clx_0.6.1/clx.asd 2005-03-30 23:55:19.000000000 -0600
+@@ -35,7 +35,7 @@
+ (defclass legacy-file (static-file) ())
+
+ (defsystem CLX
+- :depends-on (sb-bsd-sockets)
++ :depends-on (#+sbcl sb-bsd-sockets)
+ :version "0.6.1"
+ :serial t
+ :default-component-class clx-source-file
+Only in clx_0.6.1: clx.asd.~1.23.~
+diff -ur clx_0.6.1.orig/depdefs.lisp clx_0.6.1/depdefs.lisp
+--- clx_0.6.1.orig/depdefs.lisp 2003-06-05 15:18:22.000000000 -0500
++++ clx_0.6.1/depdefs.lisp 2005-03-31 00:15:05.000000000 -0600
+@@ -400,10 +400,10 @@
+ (eval-when (:compile-toplevel :load-toplevel :execute)
+ ;; FIXME: maybe we should reevaluate this?
+ (defvar *def-clx-class-use-defclass*
+- #+Genera t
++ #+(or Genera sbcl) t
+ #+(and cmu pcl) '(XLIB:DRAWABLE XLIB:WINDOW XLIB:PIXMAP)
+ #+(and cmu (not pcl)) nil
+- #-(or Genera cmu) nil
++ #-(or Genera cmu sbcl) nil
+ "Controls whether DEF-CLX-CLASS uses DEFCLASS.
+
+ If it is a list, it is interpreted by DEF-CLX-CLASS to be a list of
+Only in clx_0.6.1: depdefs.lisp.~1.4.~
+diff -ur clx_0.6.1.orig/dependent.lisp clx_0.6.1/dependent.lisp
+--- clx_0.6.1.orig/dependent.lisp 2004-06-11 07:18:17.000000000 -0500
++++ clx_0.6.1/dependent.lisp 2005-03-31 00:20:25.000000000 -0600
+@@ -1511,11 +1511,16 @@
+ (cdr (host-address host)))
+ :foreign-port (+ *x-tcp-port* display)))
+
+-#+(or sbcl ecl)
++#+(or sbcl ecl cmu)
+ (defconstant +X-unix-socket-path+
+ "/tmp/.X11-unix/X"
+ "The location of the X socket")
+
++#+(or sbcl ecl CMU)
++(defconstant +X-tcp-port+
++ 6000
++ "The TCP port number for X")
++
+ #+sbcl
+ (defun open-x-stream (host display protocol)
+ (declare (ignore protocol)
+@@ -1528,11 +1533,22 @@
+ (let ((host (car (host-ent-addresses (get-host-by-name host)))))
+ (when host
+ (let ((s (make-instance 'inet-socket :type :stream :protocol :tcp)))
+- (socket-connect s host (+ 6000 display))
++ (socket-connect s host (+ +X-tcp-port+ display))
+ s))))
+ :element-type '(unsigned-byte 8)
+ :input t :output t :buffering :none))
+
++#+CMU
++(defun open-x-stream (host display protocol)
++ (declare (ignore protocol)
++ (type (integer 0) display))
++ (system:make-fd-stream
++ (if (or (string= host "") (string= host "unix"))
++ (ext:connect-to-unix-socket (format nil "~A~D" +X-unix-socket-path+ display))
++ (ext:connect-to-inet-socket host (+ +X-tcp-port+ display)))
++ :input t :output t :element-type '(unsigned-byte 8)))
++
++
+ #+ecl
+ (defun open-x-stream (host display protocol)
+ (declare (ignore protocol)
+@@ -1541,7 +1557,7 @@
+ (if (or (string= host "") (string= host "unix")) ; AF_UNIX doamin socket
+ (sys::open-unix-socket-stream
+ (format nil "~A~D" +X-unix-socket-path+ display))
+- (si::open-client-stream host (+ 6000 display)))))
++ (si::open-client-stream host (+ +X-tcp-port+ display)))))
+
+ ;;; BUFFER-READ-DEFAULT - read data from the X stream
+
+@@ -3092,7 +3108,7 @@
+ (defmacro with-underlying-simple-vector
+ ((variable element-type pixarray) &body body)
+ (declare (ignore element-type))
+- `(#+cmu kernel::with-array-data #+sbcl sb-kernel:with-array-data
++ `(#+cmu lisp::with-array-data #+sbcl sb-kernel:with-array-data
+ ((,variable ,pixarray) (start) (end))
+ (declare (ignore start end))
+ ,@body))
+@@ -3505,11 +3521,11 @@
+ height width)
+ (declare (type array-index source-width sx sy dest-width dx dy height width))
+ #.(declare-buffun)
+- (kernel::with-array-data ((sdata source)
++ (lisp::with-array-data ((sdata source)
+ (sstart)
+ (send))
+ (declare (ignore send))
+- (kernel::with-array-data ((ddata dest)
++ (lisp::with-array-data ((ddata dest)
+ (dstart)
+ (dend))
+ (declare (ignore dend))
+Only in clx_0.6.1: dependent.lisp.~1.19.~
diff --git a/dev-lisp/cl-clx/metadata.xml b/dev-lisp/cl-clx/metadata.xml
new file mode 100644
index 000000000000..60e063702b53
--- /dev/null
+++ b/dev-lisp/cl-clx/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+<longdescription>
+CLX is an X11 client library for Common Lisp. The code was originally
+taken from a CMUCL distribution, was modified somewhat in order to
+make it compile and run under SBCL and other implementation, then a
+selection of patches were added from other CLXes around the net. Main
+features:
+
+ - SHAPE extension
+ - XFREE86-VIDMODE extension
+ - experimental RENDER extension
+ - X Authority support that works with SSH forwarding
+
+CLX is to Common Lisp, what xlib is to C.
+</longdescription>
+</pkgmetadata>