summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosé María Alonso Josa <nimiux@gentoo.org>2015-12-17 23:35:03 +0100
committerJosé María Alonso Josa <nimiux@gentoo.org>2015-12-17 23:35:03 +0100
commit813b273e70add1c1479759913dd95b4786f74350 (patch)
tree836d6070dff2f27c1a3f69a63308a6592a29d8d5 /dev-lisp/cl-ppcre-unicode
parentdev-lisp/cl-ppcre: bump to version 2.0.11 (diff)
downloadgentoo-813b273e70add1c1479759913dd95b4786f74350.tar.gz
gentoo-813b273e70add1c1479759913dd95b4786f74350.tar.bz2
gentoo-813b273e70add1c1479759913dd95b4786f74350.zip
dev-lisp/cl-ppcre-unicode: add from lisp overlay
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-lisp/cl-ppcre-unicode')
-rw-r--r--dev-lisp/cl-ppcre-unicode/Manifest1
-rw-r--r--dev-lisp/cl-ppcre-unicode/cl-ppcre-unicode-2.0.11.ebuild29
-rw-r--r--dev-lisp/cl-ppcre-unicode/metadata.xml16
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-lisp/cl-ppcre-unicode/Manifest b/dev-lisp/cl-ppcre-unicode/Manifest
new file mode 100644
index 000000000000..2e1534095069
--- /dev/null
+++ b/dev-lisp/cl-ppcre-unicode/Manifest
@@ -0,0 +1 @@
+DIST cl-ppcre-2.0.11.tar.gz 158418 SHA256 ed8571915216788dc4f6cdb44e49b0e0782e203ed547fe2e58cd5b0e5c57edc4 SHA512 c693c568065c0571e5509599018e58951425a857cec3793312af0d22e248e32233f924eafc8ba67fbedad38cb3f4efa11343b785b073eaac53c31871422488b1 WHIRLPOOL 85e0bda97b1bea3da32fbe9a56dd45eb6926fccb7546ee41528a4c6b7b079a94f0d30c59d98cd0288ea26efe6b004b6856cabaaeb3cb93e441cdebc5d588bdf7
diff --git a/dev-lisp/cl-ppcre-unicode/cl-ppcre-unicode-2.0.11.ebuild b/dev-lisp/cl-ppcre-unicode/cl-ppcre-unicode-2.0.11.ebuild
new file mode 100644
index 000000000000..9cb11ed36495
--- /dev/null
+++ b/dev-lisp/cl-ppcre-unicode/cl-ppcre-unicode-2.0.11.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit common-lisp-3
+
+MY_P="v${PV}"
+
+DESCRIPTION="CL-PPCRE is a portable regular expression library for Common Lisp."
+HOMEPAGE="http://weitz.de/cl-ppcre/
+ http://www.cliki.net/cl-ppcre"
+SRC_URI="https://github.com/edicl/cl-ppcre/archive/${MY_P}.tar.gz -> cl-ppcre-${PV}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="=dev-lisp/cl-ppcre-${PV}*
+ dev-lisp/cl-unicode"
+
+S="${WORKDIR}/cl-ppcre-${PV}"
+
+src_install() {
+ common-lisp-install-sources ${PN}/ test/unicode*
+ common-lisp-install-asdf ${PN}
+}
diff --git a/dev-lisp/cl-ppcre-unicode/metadata.xml b/dev-lisp/cl-ppcre-unicode/metadata.xml
new file mode 100644
index 000000000000..a1563ab58b8b
--- /dev/null
+++ b/dev-lisp/cl-ppcre-unicode/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+ <longdescription>
+ CL-PPCRE is a portable regular expression library for Common Lisp
+ which has the following features:
+
+ * compatible with Perl
+ * fast (outperforms Perl)
+ * portable (ANSI Common Lisp)
+ * thread-safe
+ * includes convenience features
+ * well-documented.
+ </longdescription>
+</pkgmetadata>