summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2021-03-27 15:33:46 +0700
committerAndrey Grozin <grozin@gentoo.org>2021-03-27 15:33:46 +0700
commit2fad015bed504bae2475b2c6ac66925f5e71692b (patch)
tree33d21ac8b659f19f29cff33da3d9d002c855e0f2 /dev-lisp/clozurecl
parentdev-ruby/activestorage: account for new marcel slot (diff)
downloadgentoo-2fad015bed504bae2475b2c6ac66925f5e71692b.tar.gz
gentoo-2fad015bed504bae2475b2c6ac66925f5e71692b.tar.bz2
gentoo-2fad015bed504bae2475b2c6ac66925f5e71692b.zip
dev-lisp/clozurecl: bump to 1.12
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'dev-lisp/clozurecl')
-rw-r--r--dev-lisp/clozurecl/Manifest3
-rw-r--r--dev-lisp/clozurecl/clozurecl-1.12.ebuild98
2 files changed, 101 insertions, 0 deletions
diff --git a/dev-lisp/clozurecl/Manifest b/dev-lisp/clozurecl/Manifest
index bfc4b91eba63..e0ec043115bf 100644
--- a/dev-lisp/clozurecl/Manifest
+++ b/dev-lisp/clozurecl/Manifest
@@ -2,4 +2,7 @@ DIST ccl-1.11.5-darwinx86.tar.gz 100515656 BLAKE2B d9ae52f7d0c481211fdf53bf6bb4b
DIST ccl-1.11.5-linuxarm.tar.gz 40288609 BLAKE2B 5217de314e6c59e5bbee7d5608b4e92088fb57dc0d8a90454ec4653c1710857748776d9a7ee2e89e86613f64fc028aca324ea5cb3bc7eb5e9bc582e2b50766cf SHA512 0305baa66263a2182ba8deb02837287ffb6c1472987d4953caa8839cad6503815ded7fe6bfde72a823b90d3ff86322602ee3d0934e179fb2418e3b049f55be4e
DIST ccl-1.11.5-linuxx86.tar.gz 50652181 BLAKE2B 2ed6e747a72816c6f79f58715261c41a1c3b98fa84ef4ee82ca5683383741777a46a566c7884d7fdc3dcd2e5959dab2f3fde9432945a4dc73bcece8f741ed753 SHA512 b6c16d9bba27a901f942237ed42d6b3e832910951270820a2a3d61afe2a8e7f59d383c854382cfcaa0bf8253c8d624be66d905b4170211ea39a106ca85b9a23d
DIST ccl-1.11.5-solarisx86.tar.gz 59139069 BLAKE2B db1a904dd4e794127e7c966a9734aa92bb0415520a6af35d92008fd785004bd2ea04deb66f600b1d1dd60c0b95519e86d412b208878aaa6c2f9f8c05a27efe38 SHA512 4ae7cee7e35de41ab20d79e073b12b6bd98a23beea95c0de7d882a1f4e1ea3f9f3162844df0578aeeadb671d30a0a488092ee93b35245c693051a4ab9193fc5b
+DIST ccl-1.12-darwinx86.tar.gz 23943561 BLAKE2B 99bddb8b0de0aeb6038301fe74265bc8dd5f8d69122cd50bb06831b3d83c08837bf7b05b74a03fa9ce6ed90025192ee14e66d642a32b08da03c8bb2b7455e9da SHA512 d56bae52af8b89d013226148a754e21e77e088c2060547adbeb93007c2cc3f2b1457099972205e8bdb3ae6d8359058658dd3ad7c6bdda2f3555b6eaed7268859
+DIST ccl-1.12-linuxx86.tar.gz 20878539 BLAKE2B 474b8ff10131ba50b208060aa8f822361c019d5a483f71baf49663b83f1207291e45950e3e7fe741638318b014891bb717574f01632fd069ec801bceac99c124 SHA512 70ba4bb49b560ea2fd51603ae3ca4fba270ab00d94ef87ed8f4910397eaab11d28ccd69573e2ada1c3023d15c2b2fd6a7184575665de1c799768cd1c6f55de06
+DIST ccl-1.12-solarisx86.tar.gz 16902471 BLAKE2B 640eeb6f4673d3d2e824c0726e935c391961d70be4360476cba41af79864a60dbcf9769a6ef2938c5363fd7107c5f058e85b31cca5deb45c9c134f48540816ba SHA512 aa5ce2186ebd8093d21e71907ee0b4d33fc6d4ced456fbec4aa2f3434943df1ad5b3d5473a5d626e26b24607b9c6cfe03cb1c0ec14eeb1347df79f9136c756b5
DIST ccl.html 962003 BLAKE2B fc95ec5abbea7c2f5f247293691a5c5a7eddaa049156c38766ec9df4d1920fdee902c89db976cc6687535aef5ddda3c672b62156bf0f61b6369ade548dcb0141 SHA512 0cb9ee8f7eb6007e08241a0797519ff3bfc3d3adc0b5ac86e6a2e9e8b2e316fc421bea3b04159decc0a2b37ff7098147e25266946cc3c1ac367b93e4821a8b64
diff --git a/dev-lisp/clozurecl/clozurecl-1.12.ebuild b/dev-lisp/clozurecl/clozurecl-1.12.ebuild
new file mode 100644
index 000000000000..87c35ade0caf
--- /dev/null
+++ b/dev-lisp/clozurecl/clozurecl-1.12.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils flag-o-matic multilib toolchain-funcs vcs-clean
+
+MY_PN=ccl
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Common Lisp implementation, derived from Digitool's MCL product"
+HOMEPAGE="https://ccl.clozure.com"
+SRC_URI="
+ x86? ( https://github.com/Clozure/ccl/releases/download/v${PV}/${MY_P}-linuxx86.tar.gz )
+ amd64? ( https://github.com/Clozure/ccl/releases/download/v${PV}/${MY_P}-linuxx86.tar.gz )
+ x64-macos? ( https://github.com/Clozure/ccl/releases/download/v${PV}/${MY_P}-darwinx86.tar.gz )
+ x86-solaris? ( https://github.com/Clozure/ccl/releases/download/v${PV}/${MY_P}-solarisx86.tar.gz )
+ x64-solaris? ( https://github.com/Clozure/ccl/releases/download/v${PV}/${MY_P}-solarisx86.tar.gz )
+ doc? ( https://ccl.clozure.com/docs/ccl.html )"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="doc"
+
+RDEPEND=">=dev-lisp/asdf-2.33-r3:="
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${MY_PN}
+ENVD="${T}/50ccl"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.11.5-no-pie-32.patch
+ "${FILESDIR}"/${PN}-1.11.5-fno-common.patch
+)
+
+src_prepare() {
+ default
+ cp "${EPREFIX}/usr/share/common-lisp/source/asdf/build/asdf.lisp" tools/ || die
+}
+
+src_configure() {
+ if use x64-macos; then
+ CCL_RUNTIME=dx86cl64; CCL_HEADERS=darwin-x86-headers64; CCL_KERNEL=darwinx8664
+ elif use x86-solaris; then
+ CCL_RUNTIME=sx86cl; CCL_HEADERS=solarisx86-headers; CCL_KERNEL=solarisx86
+ elif use x64-solaris; then
+ CCL_RUNTIME=sx86cl64; CCL_HEADERS=solarisx64-headers; CCL_KERNEL=solarisx64
+ elif use x86; then
+ CCL_RUNTIME=lx86cl; CCL_HEADERS=x86-headers; CCL_KERNEL=linuxx8632
+ elif use amd64; then
+ CCL_RUNTIME=lx86cl64; CCL_HEADERS=x86-headers64; CCL_KERNEL=linuxx8664
+ elif use arm; then
+ CCL_RUNTIME=armcl; CCL_HEADERS=arm-headers; CCL_KERNEL=linuxarm
+ elif use ppc; then
+ CCL_RUNTIME=ppccl; CCL_HEADERS=headers; CCL_KERNEL=linuxppc
+ elif use ppc64; then
+ CCL_RUNTIME=ppccl64; CCL_HEADERS=headers64; CCL_KERNEL=linuxppc64
+ fi
+}
+
+src_compile() {
+ emake -C lisp-kernel/${CCL_KERNEL} clean
+ emake -C lisp-kernel/${CCL_KERNEL} all CC="$(tc-getCC)"
+
+ unset CCL_DEFAULT_DIRECTORY
+ ./${CCL_RUNTIME} -n -b -Q -e '(ccl:rebuild-ccl :full t)' -e '(ccl:quit)' || die "Compilation failed"
+
+ # remove non-owner write permissions on the full-image
+ chmod go-w ${CCL_RUNTIME}{,.image} || die
+
+ esvn_clean
+}
+
+src_install() {
+ local target_dir="/usr/$(get_libdir)/${PN}"
+ local prefix_dir="${EPREFIX}/${target_dir#/}"
+
+ mkdir -p "${D}/${prefix_dir#/}"
+
+ find . -type f -name '*fsl' -delete || die
+ rm -f lisp-kernel/${CCL_KERNEL}/*.o || die
+ cp -a compiler level-0 level-1 lib library lisp-kernel scripts \
+ tools xdump ${CCL_HEADERS} ${CCL_RUNTIME} ${CCL_RUNTIME}.image \
+ "${D}/${prefix_dir#/}" || die
+
+ echo "CCL_DEFAULT_DIRECTORY=${prefix_dir}" > "${ENVD}"
+ doenvd "${ENVD}"
+
+ dosym "${target_dir}/${CCL_RUNTIME}" /usr/bin/ccl
+ dodoc doc/release-notes.txt
+
+ if use doc ; then
+ dodoc "${DISTDIR}/ccl.html"
+ dodoc -r doc/manual
+ dodoc -r examples
+ fi
+}