summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChema Alonso Josa <nimiux@gentoo.org>2018-02-04 11:19:32 +0100
committerChema Alonso Josa <nimiux@gentoo.org>2018-02-04 11:20:00 +0100
commit18aefe8743346feadfdb405dcafc344e53fc024d (patch)
tree63bf7838b4d7de5638030b5c7e60342ee138fb18 /dev-lisp/clx/clx-0.7.5.ebuild
parentsci-libs/gdal: Drop old (diff)
downloadgentoo-18aefe8743346feadfdb405dcafc344e53fc024d.tar.gz
gentoo-18aefe8743346feadfdb405dcafc344e53fc024d.tar.bz2
gentoo-18aefe8743346feadfdb405dcafc344e53fc024d.zip
dev-lisp/clx: Bumps version to 0.7.5
Closes: https://bugs.gentoo.org/646534 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-lisp/clx/clx-0.7.5.ebuild')
-rw-r--r--dev-lisp/clx/clx-0.7.5.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-lisp/clx/clx-0.7.5.ebuild b/dev-lisp/clx/clx-0.7.5.ebuild
new file mode 100644
index 000000000000..8cd18ea3e421
--- /dev/null
+++ b/dev-lisp/clx/clx-0.7.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit common-lisp-3 eutils
+
+DESCRIPTION="CLX is the Common Lisp interface to the X11 protocol primarily for SBCL."
+HOMEPAGE="http://www.cliki.net/CLX"
+SRC_URI="https://github.com/sharplispers/clx/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="doc"
+
+DEPEND="sys-apps/texinfo
+ doc? ( virtual/texi2dvi )"
+RDEPEND="!dev-lisp/cl-${PN}"
+
+src_compile() {
+ cd manual || die
+ makeinfo ${PN}.texinfo -o ${PN}.info || die
+ if use doc ; then
+ VARTEXFONTS="${T}"/fonts \
+ texi2pdf ${PN}.texinfo -o ${PN}.pdf || die
+ fi
+}
+
+src_install() {
+ common-lisp-install-sources *.lisp debug demo extensions tests
+ common-lisp-install-asdf
+ dodoc NEWS CHANGES README*
+ doinfo manual/${PN}.info
+ use doc && dodoc manual/${PN}.pdf
+}