summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny YUE <sheepduke@gmail.com>2019-03-14 22:51:26 +0800
committerJoonas Niilola <juippis@gentoo.org>2019-08-01 16:13:19 +0300
commit6b2e4dfcd97fc8d18a7796bfd44682c7235d7122 (patch)
tree983cc5ca57aebeba8c4b9bd9998c0d75c39e723d /dev-lisp/roswell
parentarm64/p.u.s.m: app-text/docbook2X fails test (diff)
downloadgentoo-6b2e4dfcd97fc8d18a7796bfd44682c7235d7122.tar.gz
gentoo-6b2e4dfcd97fc8d18a7796bfd44682c7235d7122.tar.bz2
gentoo-6b2e4dfcd97fc8d18a7796bfd44682c7235d7122.zip
dev-lisp/roswell: Add roswell ebuild
Signed-off-by: YUE Daian <sheepduke@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/10684 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-lisp/roswell')
-rw-r--r--dev-lisp/roswell/Manifest1
-rw-r--r--dev-lisp/roswell/metadata.xml20
-rw-r--r--dev-lisp/roswell/roswell-19.3.10.97.ebuild32
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-lisp/roswell/Manifest b/dev-lisp/roswell/Manifest
new file mode 100644
index 000000000000..8544f975e329
--- /dev/null
+++ b/dev-lisp/roswell/Manifest
@@ -0,0 +1 @@
+DIST roswell-19.3.10.97.tar.gz 159870 BLAKE2B 3a39f2606da3e45e752490eaba2b44f2dfc369c073e65d7556d078e6b6e4e1e620b24b5ef50375d01d5cd88a68c08825bf84b953965d1409f07ed2ba92ccf64c SHA512 53265610715dcc8d5b23d10e6dff18bf7e69fd4884e45741f9165647b6003f219e0a4b3ab21c9a5bb5dd3c72240aa6e0f091a4379c792d5ed40787fa382a71af
diff --git a/dev-lisp/roswell/metadata.xml b/dev-lisp/roswell/metadata.xml
new file mode 100644
index 000000000000..020c3a635287
--- /dev/null
+++ b/dev-lisp/roswell/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sheepduke@gmail.com</email>
+ <name>YUE Daian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ Roswell is the de facto full-stack environment for Common Lisp
+ development. It serves as a Lisp implementation installer, manager,
+ launcher etc.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">roswell/roswell</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-lisp/roswell/roswell-19.3.10.97.ebuild b/dev-lisp/roswell/roswell-19.3.10.97.ebuild
new file mode 100644
index 000000000000..7c7198c265e6
--- /dev/null
+++ b/dev-lisp/roswell/roswell-19.3.10.97.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="A lisp installer and launcher for major environment"
+HOMEPAGE="https://github.com/roswell/roswell"
+SRC_URI="https://github.com/roswell/roswell/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_test() {
+ emake -j1 check
+}
+
+src_install() {
+ emake DESTDIR="${D}" -j1 install
+}