summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosé María Alonso Josa <nimiux@gentoo.org>2015-12-15 23:24:20 +0100
committerJosé María Alonso Josa <nimiux@gentoo.org>2015-12-15 23:24:20 +0100
commit9653d4d64b577b06f1b7c50edb22abdd9f4168f9 (patch)
tree82c688fd9eb08629a1f5fa95c1b87a753502a19b /dev-lisp
parentMerge remote-tracking branch 'github/pr/478'. (diff)
downloadgentoo-9653d4d64b577b06f1b7c50edb22abdd9f4168f9.tar.gz
gentoo-9653d4d64b577b06f1b7c50edb22abdd9f4168f9.tar.bz2
gentoo-9653d4d64b577b06f1b7c50edb22abdd9f4168f9.zip
dev-lisp/flexi-streams: add from lisp overlay
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/flexi-streams/Manifest1
-rw-r--r--dev-lisp/flexi-streams/flexi-streams-1.0.15.ebuild28
-rw-r--r--dev-lisp/flexi-streams/metadata.xml12
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-lisp/flexi-streams/Manifest b/dev-lisp/flexi-streams/Manifest
new file mode 100644
index 000000000000..3a09bbea6721
--- /dev/null
+++ b/dev-lisp/flexi-streams/Manifest
@@ -0,0 +1 @@
+DIST v1.0.15.tar.gz 135550 SHA256 1c9d8020cfd2bf0344e5baf1dff8b01aa7cefcdc5bc3765d029bd2e723d00251 SHA512 103e6c53f8c0ffd6d218e08e49fd49c21f420c1221912121dba1218d4631b6869357002fb1a18444e58283e2d6e59ae3f43d5a23c06c506538d69f4a178b3973 WHIRLPOOL d8a88f21b26079f86d5deb55cfeae0bc4c7f34d853e4b2a887eeb829f38e5be8d8902dea675caa7d373503f25c798b2492d6a1212fb58ea15e352e1c3c9b90fa
diff --git a/dev-lisp/flexi-streams/flexi-streams-1.0.15.ebuild b/dev-lisp/flexi-streams/flexi-streams-1.0.15.ebuild
new file mode 100644
index 000000000000..54995d59fbc4
--- /dev/null
+++ b/dev-lisp/flexi-streams/flexi-streams-1.0.15.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit common-lisp-3
+
+MY_V="v${PV}"
+
+DESCRIPTION="Flexible bivalent streams for Common Lisp"
+HOMEPAGE="http://weitz.de/flexi-streams/
+ http://www.cliki.net/flexi-streams/"
+SRC_URI="https://github.com/edicl/${PN}/archive/${MY_V}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="!dev-lisp/cl-${PN}
+ >=dev-lisp/trivial-gray-streams-20060925"
+
+src_install() {
+ common-lisp-install-sources *.lisp
+ common-lisp-install-asdf
+ dohtml doc/index.html
+}
diff --git a/dev-lisp/flexi-streams/metadata.xml b/dev-lisp/flexi-streams/metadata.xml
new file mode 100644
index 000000000000..417d4b8ab72a
--- /dev/null
+++ b/dev-lisp/flexi-streams/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>common-lisp</herd>
+ <longdescription lang="en">
+ FLEXI-STREAMS implements "virtual" bivalent streams that can be
+ layered atop real binary or bivalent streams and that can be used
+ to read and write character data in various single- or multi-octet
+ encodings which can be changed on the fly. It also supplies
+ in-memory binary streams which are similar to string streams.
+ </longdescription>
+</pkgmetadata>