summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2015-09-22 10:50:18 +0600
committerAndrey Grozin <grozin@gentoo.org>2015-09-22 10:50:18 +0600
commite53567187f146ee1f52d537d6f2efacb6a91f4c1 (patch)
tree4eba1c31505cc711e4f56d4eb72c3aa0354aeea4 /dev-lisp
parentmedia-gfx/gif2png: Stable for PPC64 (bug #535440). (diff)
downloadgentoo-e53567187f146ee1f52d537d6f2efacb6a91f4c1.tar.gz
gentoo-e53567187f146ee1f52d537d6f2efacb6a91f4c1.tar.bz2
gentoo-e53567187f146ee1f52d537d6f2efacb6a91f4c1.zip
dev-lisp/sbcl: comment out a test in posix-tests.lisp
Bugs: 560276, 561018 Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/sbcl/files/sb-posix-test-1.2.15.patch40
-rw-r--r--dev-lisp/sbcl/metadata.xml2
-rw-r--r--dev-lisp/sbcl/sbcl-1.2.15.ebuild2
3 files changed, 42 insertions, 2 deletions
diff --git a/dev-lisp/sbcl/files/sb-posix-test-1.2.15.patch b/dev-lisp/sbcl/files/sb-posix-test-1.2.15.patch
new file mode 100644
index 000000000000..517208a791e2
--- /dev/null
+++ b/dev-lisp/sbcl/files/sb-posix-test-1.2.15.patch
@@ -0,0 +1,40 @@
+diff -r -U1 sbcl-1.2.15.orig/contrib/sb-posix/posix-tests.lisp sbcl-1.2.15/contrib/sb-posix/posix-tests.lisp
+--- sbcl-1.2.15.orig/contrib/sb-posix/posix-tests.lisp 2015-08-31 00:59:03.000000000 +0600
++++ sbcl-1.2.15/contrib/sb-posix/posix-tests.lisp 2015-09-22 10:19:20.000000000 +0600
+@@ -169,19 +169,19 @@
+
+-(deftest rmdir.error.3
+- (handler-case
+- (sb-posix:rmdir #-win32 "/" #+win32 (sb-ext:posix-getenv "windir"))
+- (sb-posix:syscall-error (c)
+- (typep
+- (sb-posix:syscall-errno c)
+- '(member
+- #+(or darwin openbsd)
+- #.sb-posix:eisdir
+- #+win32
+- #.sb-posix::eacces
+- #+win32
+- #.sb-posix::enotempty
+- #+sunos
+- #.sb-posix::einval
+- #-(or darwin openbsd win32 sunos)
+- #.sb-posix::ebusy)))) t)
++;(deftest rmdir.error.3
++; (handler-case
++; (sb-posix:rmdir #-win32 "/" #+win32 (sb-ext:posix-getenv "windir"))
++; (sb-posix:syscall-error (c)
++; (typep
++; (sb-posix:syscall-errno c)
++; '(member
++; #+(or darwin openbsd)
++; #.sb-posix:eisdir
++; #+win32
++; #.sb-posix::eacces
++; #+win32
++; #.sb-posix::enotempty
++; #+sunos
++; #.sb-posix::einval
++; #-(or darwin openbsd win32 sunos)
++; #.sb-posix::ebusy)))) t)
+
diff --git a/dev-lisp/sbcl/metadata.xml b/dev-lisp/sbcl/metadata.xml
index 04e46eae8af5..bad39a3536fa 100644
--- a/dev-lisp/sbcl/metadata.xml
+++ b/dev-lisp/sbcl/metadata.xml
@@ -28,8 +28,6 @@
GLIBC. SBCL 0.8.17 and later support Unicode.
</longdescription>
<use>
- <flag name="asdf">Include support for <pkg>dev-lisp/asdf in SBCL</pkg></flag>
- <flag name="ldb">Include support for the SBCL low level debugger</flag>
<flag name="pax_kernel">Enable if the user plans to run the package under a pax enabled hardened kernel</flag>
</use>
<upstream>
diff --git a/dev-lisp/sbcl/sbcl-1.2.15.ebuild b/dev-lisp/sbcl/sbcl-1.2.15.ebuild
index fd1bea7afdfa..bc2ac4d3c116 100644
--- a/dev-lisp/sbcl/sbcl-1.2.15.ebuild
+++ b/dev-lisp/sbcl/sbcl-1.2.15.ebuild
@@ -98,6 +98,8 @@ src_prepare() {
epatch "${FILESDIR}"/concurrency-test-1.2.6.patch
# bugs #486552, #527666, #517004
epatch "${FILESDIR}"/bsd-sockets-test-1.2.11.patch
+ # bugs #560276, #561018
+ epatch "${FILESDIR}"/sb-posix-test-1.2.15.patch
epatch "${FILESDIR}"/${PN}-1.2.11-solaris.patch
epatch "${FILESDIR}"/${PN}-1.2.13-verbose-build.patch