summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-04-14 21:35:25 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-04-14 22:08:31 +0200
commitc0ed5d49c89c21cd574db083270a5154b0d8a615 (patch)
treed0dd3ab3f3550dcee55216ca5372bbafd4822618 /dev-lua/lua-argparse
parentapp-emulation/docker-compose: 1.29.1 (diff)
downloadgentoo-c0ed5d49c89c21cd574db083270a5154b0d8a615.tar.gz
gentoo-c0ed5d49c89c21cd574db083270a5154b0d8a615.tar.bz2
gentoo-c0ed5d49c89c21cd574db083270a5154b0d8a615.zip
dev-lua/lua-argparse: drop old version
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/lua-argparse')
-rw-r--r--dev-lua/lua-argparse/Manifest1
-rw-r--r--dev-lua/lua-argparse/lua-argparse-0.6.0-r100.ebuild60
2 files changed, 0 insertions, 61 deletions
diff --git a/dev-lua/lua-argparse/Manifest b/dev-lua/lua-argparse/Manifest
index 2d0fc3a81478..a1d43f077e56 100644
--- a/dev-lua/lua-argparse/Manifest
+++ b/dev-lua/lua-argparse/Manifest
@@ -1,2 +1 @@
-DIST lua-argparse-0.6.0.tar.gz 36712 BLAKE2B 88882738453a894db68ef93557d870393eaec1fb2bf39b110bd2691678d26be64734d07c7f01f760d9c1d031e530707449ff2ca54a5cdd428cb8da3b1897a7e1 SHA512 7efdfab8ec563a9e7eddc7aff760fd4d3605df2896939af3f2c80e5ed4d4e5ba45a7815057e15446d242351a6fd139d6b8da802fe318d4a4bcd69918fece53d1
DIST lua-argparse-0.7.1.tar.gz 43778 BLAKE2B 6bc6a3dee3fd98cb8c00fa3ccb3ae9ffdb9f2707d80dd7f5717e1265430731957b756672ed4acd9222c686108f8a8b8c71c71285c2540e818396faf302c1d287 SHA512 f192d0c591516a74408a19c0bbf34233be180f63794211a951d19fc8d981749bc71eace16a4680c8f2bb302ab48958c6a9ffc84022a1754275fc1f9113ae32b0
diff --git a/dev-lua/lua-argparse/lua-argparse-0.6.0-r100.ebuild b/dev-lua/lua-argparse/lua-argparse-0.6.0-r100.ebuild
deleted file mode 100644
index d331efad3b86..000000000000
--- a/dev-lua/lua-argparse/lua-argparse-0.6.0-r100.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-LUA_COMPAT=( lua5-{1..3} luajit )
-
-inherit lua toolchain-funcs
-
-DESCRIPTION="Command line argument parser for the Lua Programming Language"
-HOMEPAGE="https://github.com/mpeterv/argparse"
-SRC_URI="https://github.com/mpeterv/${PN/lua-/}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN//lua-/}-${PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ppc ppc64 x86"
-IUSE="doc test"
-
-RESTRICT="!test? ( test )"
-
-RDEPEND="${LUA_DEPS}"
-DEPEND="${RDEPEND}"
-BDEPEND="
- virtual/pkgconfig
- doc? ( dev-python/sphinx )
- test? (
- dev-lua/busted[${LUA_USEDEP}]
- ${RDEPEND}
- )
-"
-
-src_compile() {
- if use doc; then
- sphinx-build docsrc html || die
- rm -rf "${S}"/html/{.doctrees,_sources} || die
- fi
-}
-
-lua_src_test() {
- busted --exclude-tags="unsafe" --lua=${ELUA} || die
-}
-
-src_test() {
- lua_foreach_impl lua_src_test
-}
-
-lua_src_install() {
- insinto "$(lua_get_lmod_dir)"
- doins src/argparse.lua
-}
-
-src_install() {
- default
-
- use doc && local -a HTML_DOCS=( "html/." )
- einstalldocs
-
- lua_foreach_impl lua_src_install
-}