summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-11-14 15:02:43 +0100
committerConrad Kostecki <conikost@gentoo.org>2020-11-14 15:03:27 +0100
commit8e322bbaa36304af377d3086b11bd45287d99f6e (patch)
tree8f26a798f9ef13695ebc933542b697de6cdb73b0 /dev-lua/lua-bit32
parentsys-kernel/gentoo-kernel: Use externalized configs for 5.9.8-r1 (diff)
downloadgentoo-8e322bbaa36304af377d3086b11bd45287d99f6e.tar.gz
gentoo-8e322bbaa36304af377d3086b11bd45287d99f6e.tar.bz2
gentoo-8e322bbaa36304af377d3086b11bd45287d99f6e.zip
dev-lua/lua-bit32: migrate to lua eclass
Also added myself as co-maintainer, since this is a direct dep for net-im/prosody. Closes: https://bugs.gentoo.org/752615 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/lua-bit32')
-rw-r--r--dev-lua/lua-bit32/lua-bit32-5.3.5-r100.ebuild55
-rw-r--r--dev-lua/lua-bit32/metadata.xml26
2 files changed, 70 insertions, 11 deletions
diff --git a/dev-lua/lua-bit32/lua-bit32-5.3.5-r100.ebuild b/dev-lua/lua-bit32/lua-bit32-5.3.5-r100.ebuild
new file mode 100644
index 000000000000..ab3e7d6036c5
--- /dev/null
+++ b/dev-lua/lua-bit32/lua-bit32-5.3.5-r100.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-1 luajit )
+
+MY_PN="lua-compat-5.3"
+MY_PV="0.10"
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="Backported Lua bit manipulation library"
+HOMEPAGE="https://github.com/keplerproject/lua-compat-5.3"
+SRC_URI="https://github.com/keplerproject/${MY_PN}/archive/v${MY_PV}.tar.gz -> lua-compat53-${MY_PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${MY_PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+DEPEND="${LUA_DEPS}"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ compiler="$(tc-getCC) ${CFLAGS} -fPIC ${LDFLAGS} -DLUA_COMPAT_BITLIB -Ic-api -c lbitlib.c -o lbitlib.o"
+ einfo "${compiler}"
+ eval "${compiler}" || die
+
+ linker="$(tc-getCC) -shared ${LDFLAGS} -o bit32.so lbitlib.o"
+ einfo "${linker}"
+ eval "${linker}" || die
+}
+
+lua_src_test() {
+ LUA_CPATH="./?.so" "${ELUA}" "tests/test-bit32.lua" || die
+}
+
+src_test() {
+ lua_foreach_impl lua_src_test
+}
+
+lua_src_install() {
+ exeinto "$(lua_get_cmod_dir)"
+ doexe bit32.so
+}
+
+src_install() {
+ default
+
+ lua_foreach_impl lua_src_install
+}
diff --git a/dev-lua/lua-bit32/metadata.xml b/dev-lua/lua-bit32/metadata.xml
index 32feba463055..5ff7bd4eab78 100644
--- a/dev-lua/lua-bit32/metadata.xml
+++ b/dev-lua/lua-bit32/metadata.xml
@@ -1,15 +1,19 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>azamat.hackimov@gmail.com</email>
- <name>Azamat H. Hackimov</name>
- </maintainer>
- <maintainer type="project">
- <email>proxy-maint@gentoo.org</email>
- <name>Proxy Maintainers</name>
- </maintainer>
- <upstream>
- <remote-id type="github">keplerproject/lua-compat-5.3</remote-id>
- </upstream>
+ <maintainer type="person">
+ <email>azamat.hackimov@gmail.com</email>
+ <name>Azamat H. Hackimov</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>conikost@gentoo.org</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">keplerproject/lua-compat-5.3</remote-id>
+ </upstream>
</pkgmetadata>