summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-10-18 15:12:49 +0200
committerConrad Kostecki <conikost@gentoo.org>2020-10-18 15:12:49 +0200
commita5cbbcf9a92c406ef01c730d6ad90a822e30515c (patch)
tree44b5bc9e0da306d29bbd4ae39a4c5baeab18b388 /dev-lua/lua-bit32
parentdev-lua/lua-bit32: bump to newest version (diff)
downloadgentoo-a5cbbcf9a92c406ef01c730d6ad90a822e30515c.tar.gz
gentoo-a5cbbcf9a92c406ef01c730d6ad90a822e30515c.tar.bz2
gentoo-a5cbbcf9a92c406ef01c730d6ad90a822e30515c.zip
dev-lua/lua-bit32: drop old version
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/lua-bit32')
-rw-r--r--dev-lua/lua-bit32/Manifest1
-rw-r--r--dev-lua/lua-bit32/files/lua-bit32-5.3.5-fix-32bit-conversion.patch51
-rw-r--r--dev-lua/lua-bit32/lua-bit32-5.3.5-r1.ebuild51
3 files changed, 0 insertions, 103 deletions
diff --git a/dev-lua/lua-bit32/Manifest b/dev-lua/lua-bit32/Manifest
index ff46965f4b26..ef9392daadfa 100644
--- a/dev-lua/lua-bit32/Manifest
+++ b/dev-lua/lua-bit32/Manifest
@@ -1,2 +1 @@
DIST lua-compat53-0.10.tar.gz 53695 BLAKE2B e570aedb23b8ed7ca38c4316ffab25b93a0f9f6f0fae79af563ca8a81dd6453ac273e1f9e70674c484a2dec68749e7d53a1c1736a72616c210b8e38a31b3f191 SHA512 f7f39085f4f6b16095f41e635b4c5477b3dab5e42b5b65a9d522941a3807ea521d4a27a77293a3c9d0ecea78a1f6c2a2497394b2d220f4d7d65e23510563d46d
-DIST lua-compat53-0.9.tar.gz 53599 BLAKE2B 7d9efe0afb49c40a68b1d6c28f975080b3331e07d0aa788e0f1f77d5c360504a5cac9cca4e6074b2c64aa7ad8934df3fe2609ff8009db52b046b2f639b670213 SHA512 bec15b6e95cb5cc775785515eba1f094e453059a0ba1eefa433d328b823378b7f48d9c7a34080ad77478cffb2008bead93418f809793afa6021e6046562acc58
diff --git a/dev-lua/lua-bit32/files/lua-bit32-5.3.5-fix-32bit-conversion.patch b/dev-lua/lua-bit32/files/lua-bit32-5.3.5-fix-32bit-conversion.patch
deleted file mode 100644
index 36c0ef16cec5..000000000000
--- a/dev-lua/lua-bit32/files/lua-bit32-5.3.5-fix-32bit-conversion.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-From e245d3a18957e43ef902a59a72c8902e2e4435b9 Mon Sep 17 00:00:00 2001
-From: Philipp Janda <siffiejoe@gmx.net>
-Date: Sat, 10 Oct 2020 16:43:46 +0200
-Subject: [PATCH] Fix bit32 conversion issues for Lua 5.1 on 32 bit
-
-The default unsigned conversion procedure from upstream using
-`lua_Integer` as an intermediate value fails if `lua_Integer` has only
-32 bits (as is the case on 32 bit Lua 5.1). This fix uses a `lua_Number`
-(hopefully double) as intermediate value in those cases.
----
- lbitlib.c | 14 ++++++++++++--
- tests/test-bit32.lua | 1 +
- 2 files changed, 13 insertions(+), 2 deletions(-)
-
-diff --git a/lbitlib.c b/lbitlib.c
-index 4786c0d..db2652a 100644
---- a/lbitlib.c
-+++ b/lbitlib.c
-@@ -19,8 +19,18 @@
- #if defined(LUA_COMPAT_BITLIB) /* { */
-
-
--#define pushunsigned(L,n) lua_pushinteger(L, (lua_Integer)(n))
--#define checkunsigned(L,i) ((lua_Unsigned)luaL_checkinteger(L,i))
-+#define pushunsigned(L,n) (sizeof(lua_Integer) > 4 ? lua_pushinteger(L, (lua_Integer)(n)) : lua_pushnumber(L, (lua_Number)(n)))
-+static lua_Unsigned checkunsigned(lua_State *L, int i) {
-+ if (sizeof(lua_Integer) > 4)
-+ return (lua_Unsigned)luaL_checkinteger(L, i);
-+ else {
-+ lua_Number d = luaL_checknumber(L, i);
-+ if (d < 0)
-+ d = (d + 1) + (~(lua_Unsigned)0);
-+ luaL_argcheck(L, d >= 0 && d <= (~(lua_Unsigned)0), i, "value out of range");
-+ return (lua_Unsigned)d;
-+ }
-+}
-
-
- /* number of bits to consider in a number */
-diff --git a/tests/test-bit32.lua b/tests/test-bit32.lua
-index cc91e52..a408b7d 100755
---- a/tests/test-bit32.lua
-+++ b/tests/test-bit32.lua
-@@ -4,6 +4,7 @@ local bit32 = require("bit32")
-
-
- assert(bit32.bnot(0) == 2^32-1)
-+assert(bit32.bnot(-1) == 0)
- assert(bit32.band(1, 3, 5) == 1)
- assert(bit32.bor(1, 3, 5) == 7)
-
diff --git a/dev-lua/lua-bit32/lua-bit32-5.3.5-r1.ebuild b/dev-lua/lua-bit32/lua-bit32-5.3.5-r1.ebuild
deleted file mode 100644
index 23fec675521b..000000000000
--- a/dev-lua/lua-bit32/lua-bit32-5.3.5-r1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-# Weird upstream version descisions...
-# Result tarball may be reused for future lua-compat53 package
-LUA_COMPAT_PN="lua-compat-5.3"
-LUA_COMPAT_PV="0.9"
-
-DESCRIPTION="Backported Lua bit manipulation library"
-HOMEPAGE="https://github.com/keplerproject/lua-compat-5.3"
-SRC_URI="https://github.com/keplerproject/${LUA_COMPAT_PN}/archive/v${LUA_COMPAT_PV}.tar.gz -> lua-compat53-${LUA_COMPAT_PV}.tar.gz"
-
-S="${WORKDIR}/${LUA_COMPAT_PN}-${LUA_COMPAT_PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RESTRICT="!test? ( test )"
-
-DEPEND="dev-lang/lua:0="
-RDEPEND="${DEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-PATCHES=( "${FILESDIR}/${P}-fix-32bit-conversion.patch" )
-
-src_compile() {
- # TODO maybe sometime there will be luarocks eclass...
- compile="$(tc-getCC) ${CFLAGS} ${LDFLAGS} -fPIC -I/usr/include -c lbitlib.c -o lbitlib.o -DLUA_COMPAT_BITLIB -Ic-api"
- einfo "${compile}"
- eval "${compile}" || die
-
- link="$(tc-getCC) -shared ${LDFLAGS} -o bit32.so lbitlib.o"
- einfo "${link}"
- eval "${link}" || die
-}
-
-src_test() {
- LUA_CPATH=./?.so lua tests/test-bit32.lua || die
-}
-
-src_install() {
- exeinto $($(tc-getPKG_CONFIG) --variable INSTALL_CMOD lua)
- doexe bit32.so
- dodoc README.md
-}