summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-10-10 17:27:26 +0200
committerConrad Kostecki <conikost@gentoo.org>2020-10-10 17:27:26 +0200
commite8422e6bafceb04372c23a80d8ae636dfc588ec3 (patch)
tree1cbbd025f1001be3bb794e6e3c5dab3d2eb1356b /dev-lua/lua-bit32
parentdev-lua/lua-bit32: fix 32bit conversion (diff)
downloadgentoo-e8422e6bafceb04372c23a80d8ae636dfc588ec3.tar.gz
gentoo-e8422e6bafceb04372c23a80d8ae636dfc588ec3.tar.bz2
gentoo-e8422e6bafceb04372c23a80d8ae636dfc588ec3.zip
dev-lua/lua-bit32: drop old version
Closes: https://bugs.gentoo.org/746836 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/lua-bit32')
-rw-r--r--dev-lua/lua-bit32/lua-bit32-5.3.5.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-lua/lua-bit32/lua-bit32-5.3.5.ebuild b/dev-lua/lua-bit32/lua-bit32-5.3.5.ebuild
deleted file mode 100644
index 43d5f0cee559..000000000000
--- a/dev-lua/lua-bit32/lua-bit32-5.3.5.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-DESCRIPTION="Backported Lua bit manipulation library"
-HOMEPAGE="https://github.com/keplerproject/lua-compat-5.3"
-# Wierd upstream version descisions...
-# Result tarball may be reused for future lua-compat53 package
-LUA_COMPAT_V=0.9
-SRC_URI="https://github.com/keplerproject/lua-compat-5.3/archive/v${LUA_COMPAT_V}.tar.gz -> lua-compat53-${LUA_COMPAT_V}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RESTRICT="!test? ( test )"
-
-# Strictly for lua 5.1
-DEPEND="dev-lang/lua:0="
-RDEPEND="${DEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-S="${WORKDIR}/lua-compat-5.3-${LUA_COMPAT_V}"
-
-src_compile() {
- # TODO maybe sometime there will be luarocks eclass...
- compile="$(tc-getCC) ${CFLAGS} ${LDFLAGS} -fPIC -I/usr/include -c lbitlib.c -o lbitlib.o -DLUA_COMPAT_BITLIB -Ic-api"
- einfo "${compile}"
- eval "${compile}" || die
-
- link="$(tc-getCC) -shared ${LDFLAGS} -o bit32.so lbitlib.o"
- einfo "${link}"
- eval "${link}" || die
-}
-
-src_test() {
- LUA_CPATH=./?.so lua tests/test-bit32.lua || die
-}
-
-src_install() {
- exeinto $($(tc-getPKG_CONFIG) --variable INSTALL_CMOD lua)
- doexe bit32.so
- dodoc README.md
-}