summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2020-10-08 02:55:28 +0300
committerConrad Kostecki <conikost@gentoo.org>2020-10-08 21:13:42 +0200
commit4749b85ae8ba4047757d736b1444cb4a09ec01f6 (patch)
tree05e3f34c9f2c990f279ce9ac09990577055a8c30 /dev-lua/luaexpat
parentMasking >=dev-lua/luaexpat-1.3.3 (diff)
downloadgentoo-4749b85ae8ba4047757d736b1444cb4a09ec01f6.tar.gz
gentoo-4749b85ae8ba4047757d736b1444cb4a09ec01f6.tar.bz2
gentoo-4749b85ae8ba4047757d736b1444cb4a09ec01f6.zip
dev-lua/luaexpat: update 1.3.0 version branch
Migrate to EAPI=7, various fixes backported from 1.3.3 ebuild. Closes: https://github.com/gentoo/gentoo/pull/17813 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/luaexpat')
-rw-r--r--dev-lua/luaexpat/luaexpat-1.3.0-r2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-lua/luaexpat/luaexpat-1.3.0-r2.ebuild b/dev-lua/luaexpat/luaexpat-1.3.0-r2.ebuild
new file mode 100644
index 000000000000..720457682bf3
--- /dev/null
+++ b/dev-lua/luaexpat/luaexpat-1.3.0-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal toolchain-funcs
+
+DESCRIPTION="LuaExpat is a SAX XML parser based on the Expat library"
+HOMEPAGE="http://www.keplerproject.org/luaexpat/"
+SRC_URI="http://matthewwild.co.uk/projects/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND=">=dev-lang/lua-5.1.5-r2:0[${MULTILIB_USEDEP}]
+ >=dev-libs/expat-2.1.0-r3[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ sed -i -e 's:-g::' -e 's:-O2::' Makefile || die "sed failed"
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ emake \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CC="$(tc-getCC)" \
+ LUA_INC="-I$($(tc-getPKG_CONFIG) --variable INSTALL_INC lua)"
+}
+
+multilib_src_install() {
+ emake \
+ DESTDIR="${D}" \
+ LUA_LDIR="$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)" \
+ LUA_CDIR="$($(tc-getPKG_CONFIG) --variable INSTALL_CMOD lua)" \
+ LUA_INC="-I$($(tc-getPKG_CONFIG) --variable INSTALL_INC lua)" \
+ install
+}
+
+multilib_src_install_all() {
+ dodoc -r README doc/*
+}