summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-12-02 00:47:27 +0100
committerConrad Kostecki <conikost@gentoo.org>2020-12-02 00:53:55 +0100
commit7d07f25d36d806874108032c68116261b6d1742a (patch)
tree5560af062dac29e1b6bf542b074f4a8c3a47b841 /dev-lua/lualdap
parentdev-lua/lualdap: bump to version 1.2.5 (diff)
downloadgentoo-7d07f25d36d806874108032c68116261b6d1742a.tar.gz
gentoo-7d07f25d36d806874108032c68116261b6d1742a.tar.bz2
gentoo-7d07f25d36d806874108032c68116261b6d1742a.zip
dev-lua/lualdap: migrate to lua eclass
Closes: https://bugs.gentoo.org/752648 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/lualdap')
-rw-r--r--dev-lua/lualdap/lualdap-1.2.5-r100.ebuild88
1 files changed, 88 insertions, 0 deletions
diff --git a/dev-lua/lualdap/lualdap-1.2.5-r100.ebuild b/dev-lua/lualdap/lualdap-1.2.5-r100.ebuild
new file mode 100644
index 000000000000..af582b86b150
--- /dev/null
+++ b/dev-lua/lualdap/lualdap-1.2.5-r100.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..3} luajit )
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="A lua binding for the OpenLDAP client libraries"
+HOMEPAGE="https://github.com/lualdap/lualdap"
+SRC_URI="https://github.com/lualdap/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="test"
+
+RDEPEND="
+ net-nds/openldap
+ ${LUA_DEPS}
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ test? ( ${RDEPEND} )
+"
+
+HTML_DOCS=( "doc/us/." )
+
+src_prepare() {
+ default
+
+ lua_copy_sources
+}
+
+lua_src_compile() {
+ pushd "${BUILD_DIR}" || die
+
+ local myemakeargs=(
+ "CC=$(tc-getCC)"
+ "LBER_LIBDIR=/usr/$(get_libdir)"
+ "LDAP_LIBDIR=/usr/$(get_libdir)"
+ "LUA_INCDIR=$(lua_get_include_dir)"
+ )
+
+ emake "${myemakeargs[@]}"
+
+ popd
+}
+
+src_compile() {
+ lua_foreach_impl lua_src_compile
+}
+
+lua_src_test() {
+ pushd "${BUILD_DIR}" || die
+ LUA_CPATH="./src/?.so" ${ELUA} tests/test.lua
+ popd
+}
+
+src_install() {
+ lua_foreach_impl lua_src_test
+}
+
+lua_src_install() {
+ pushd "${BUILD_DIR}" || die
+
+ # Workaround, as 'make install' does not create this directory
+ dodir "$(lua_get_cmod_dir)"
+
+ local myemakeargs=(
+ "DESTDIR=${ED}"
+ "INST_LIBDIR=$(lua_get_cmod_dir)"
+ )
+
+ emake "${myemakeargs[@]}" install
+
+ popd
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+
+ einstalldocs
+}