summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-lua/luarocks
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-lua/luarocks')
-rw-r--r--dev-lua/luarocks/Manifest4
-rw-r--r--dev-lua/luarocks/luarocks-2.0.12.ebuild53
-rw-r--r--dev-lua/luarocks/luarocks-2.0.7.1.ebuild52
-rw-r--r--dev-lua/luarocks/luarocks-2.0.8.ebuild53
-rw-r--r--dev-lua/luarocks/luarocks-2.2.0.ebuild53
-rw-r--r--dev-lua/luarocks/metadata.xml16
6 files changed, 231 insertions, 0 deletions
diff --git a/dev-lua/luarocks/Manifest b/dev-lua/luarocks/Manifest
new file mode 100644
index 000000000000..53268271d243
--- /dev/null
+++ b/dev-lua/luarocks/Manifest
@@ -0,0 +1,4 @@
+DIST luarocks-2.0.12.tar.gz 89028 SHA256 ad4b465c5dfbdce436ef746a434317110d79f18ff79202a2697e215f4ac407ed SHA512 5ece403d7bc7804ff47ec8d0ecdea7687d530d10ddf0a800c4a2a68b69a263e68f40ab7e55e39a59ab05315d3e2bc9cf76a0618803dc8e12c7e52941b4a7053f WHIRLPOOL 1b789530b3b0973fb1291177f947e97d68aafe1efaea59ad2b4cbf39fe5cda5a9ae391efc497328fe04afbce7b75d7f396d05ee3cb9953674f1bf5581393ad6a
+DIST luarocks-2.0.7.1.tar.gz 81757 SHA256 a7da6f796e6cffd63dd7a7f9a2fdab2ca3a1461e5e5e94aa8569068b701f7272 SHA512 00f37c2baed83bbc7182a4595973bbe5c252fd7f530ebc35ba254fab727c1e6a7f743bafc25bfbde945e40d531f0e764c1f785edddef62fc6219e318bffdc6f3 WHIRLPOOL 8d2ae2abfb327b3fbfe84cd1fe4cfc1371ce68dc34548b78a36745f2dbad23f83791023e378d911287d8acecf6af9c8e3f9597552c8d01795114d464a5c78bf7
+DIST luarocks-2.0.8.tar.gz 82313 SHA256 f8abf1ab03b744a817721a0ff4a0ee454e068735efaa8d1aadcfcd0f07cdaa88 SHA512 8246b3a863197bc5bd9efad343f8f5ba22d7a34904fd3afe99f916631ee30930ec91d15298e67abf22f0bcc6cda02785a5bbc9e60b424a631162e20941d20523 WHIRLPOOL 36d9673c308861a55cb6343e9245c7359710550835a7157bfb7e1389654e9c4c9963e09d3219d6df16bc8e275b2393c8fe21f10b3bbf0279be86f67c81cd523c
+DIST luarocks-2.2.0.tar.gz 111549 SHA256 9b1a4ec7b103e2fb90a7ba8589d7e0c8523a3d6d54ac469b0bbc144292b9279c SHA512 41f32e383263485758e64df661ecfbd744369035362755c64466f2c52a8740ed941b80cab3212222d7d24e4b1a7ed9ccb84fa66c8e458526056af0b06d97224f WHIRLPOOL 6ad29916659fad936a58396bfdaf41efe056e660fa9b957e61fca6832ae0e1a7448a1eb58a304f4af82c01e23248042eab8fa39ca4f3095b0dd62e637ff167e2
diff --git a/dev-lua/luarocks/luarocks-2.0.12.ebuild b/dev-lua/luarocks/luarocks-2.0.12.ebuild
new file mode 100644
index 000000000000..9911d65fa886
--- /dev/null
+++ b/dev-lua/luarocks/luarocks-2.0.12.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils multilib
+
+DESCRIPTION="A deployment and management system for Lua modules"
+HOMEPAGE="http://www.luarocks.org"
+SRC_URI="http://luarocks.org/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="curl openssl"
+
+DEPEND="dev-lang/lua
+ curl? ( net-misc/curl )
+ openssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}
+ app-arch/unzip"
+
+src_configure() {
+ USE_MD5="md5sum"
+ USE_FETCH="wget"
+ use openssl && USE_MD5="openssl"
+ use curl && USE_FETCH="curl"
+
+ # econf doesn't work b/c it passes variables the custom configure can't
+ # handle
+ ./configure \
+ --prefix=/usr \
+ --with-lua-lib=/usr/$(get_libdir) \
+ --rocks-tree=/usr/$(get_libdir)/lua/luarocks \
+ --with-downloader=$USE_FETCH \
+ --with-md5-checker=$USE_MD5 \
+ || die "configure failed"
+}
+
+src_compile() {
+ # -j1 b/c make tries to delete files it has yet to create (bug #402005)
+ emake DESTDIR="${D}" -j1 || die "make failed"
+}
+
+src_install() {
+ # -j1 b/c otherwise it fails to find src/bin/luarocks
+ emake DESTDIR="${D}" -j1 install || die "einstall"
+}
+
+pkg_preinst() {
+ find "${D}" -type f | xargs sed -i -e "s:${D}::g" || die "sed failed"
+}
diff --git a/dev-lua/luarocks/luarocks-2.0.7.1.ebuild b/dev-lua/luarocks/luarocks-2.0.7.1.ebuild
new file mode 100644
index 000000000000..5ba4ca5949ab
--- /dev/null
+++ b/dev-lua/luarocks/luarocks-2.0.7.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils multilib
+
+DESCRIPTION="A deployment and management system for Lua modules"
+HOMEPAGE="http://www.luarocks.org"
+SRC_URI="http://luarocks.org/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="curl openssl"
+
+DEPEND="dev-lang/lua
+ curl? ( net-misc/curl )
+ openssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}
+ app-arch/unzip"
+
+src_configure() {
+ USE_MD5="md5sum"
+ USE_FETCH="wget"
+ use openssl && USE_MD5="openssl"
+ use curl && USE_FETCH="curl"
+
+ # econf doesn't work b/c it passes variables the custom configure can't
+ # handle
+ ./configure \
+ --prefix=/usr \
+ --with-lua-lib=/usr/$(get_libdir) \
+ --rocks-tree=/usr/$(get_libdir)/lua/luarocks \
+ --with-downloader=$USE_FETCH \
+ --with-md5-checker=$USE_MD5 \
+ --force-config || die "configure failed"
+}
+
+src_compile() {
+ emake DESTDIR="${D}" || die "make failed"
+}
+
+src_install() {
+ # -j1 b/c otherwise it fails with to find src/bin/luarocks
+ emake DESTDIR="${D}" -j1 install || die "einstall"
+}
+
+pkg_preinst() {
+ find "${D}" -type f | xargs sed -i -e "s:${D}::g" || die "sed failed"
+}
diff --git a/dev-lua/luarocks/luarocks-2.0.8.ebuild b/dev-lua/luarocks/luarocks-2.0.8.ebuild
new file mode 100644
index 000000000000..e9eb832bd3d2
--- /dev/null
+++ b/dev-lua/luarocks/luarocks-2.0.8.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils multilib
+
+DESCRIPTION="A deployment and management system for Lua modules"
+HOMEPAGE="http://www.luarocks.org"
+SRC_URI="http://luarocks.org/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="curl openssl"
+
+DEPEND="dev-lang/lua
+ curl? ( net-misc/curl )
+ openssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}
+ app-arch/unzip"
+
+src_configure() {
+ USE_MD5="md5sum"
+ USE_FETCH="wget"
+ use openssl && USE_MD5="openssl"
+ use curl && USE_FETCH="curl"
+
+ # econf doesn't work b/c it passes variables the custom configure can't
+ # handle
+ ./configure \
+ --prefix=/usr \
+ --with-lua-lib=/usr/$(get_libdir) \
+ --rocks-tree=/usr/$(get_libdir)/lua/luarocks \
+ --with-downloader=$USE_FETCH \
+ --with-md5-checker=$USE_MD5 \
+ --force-config || die "configure failed"
+}
+
+src_compile() {
+ # -j1 b/c make tries to delete files it has yet to create (bug #402005)
+ emake DESTDIR="${D}" -j1 || die "make failed"
+}
+
+src_install() {
+ # -j1 b/c otherwise it fails to find src/bin/luarocks
+ emake DESTDIR="${D}" -j1 install || die "einstall"
+}
+
+pkg_preinst() {
+ find "${D}" -type f | xargs sed -i -e "s:${D}::g" || die "sed failed"
+}
diff --git a/dev-lua/luarocks/luarocks-2.2.0.ebuild b/dev-lua/luarocks/luarocks-2.2.0.ebuild
new file mode 100644
index 000000000000..c1ca8a3dd5c1
--- /dev/null
+++ b/dev-lua/luarocks/luarocks-2.2.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils multilib
+
+DESCRIPTION="A deployment and management system for Lua modules"
+HOMEPAGE="http://www.luarocks.org"
+SRC_URI="http://luarocks.org/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="curl openssl"
+
+DEPEND="dev-lang/lua
+ curl? ( net-misc/curl )
+ openssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}
+ app-arch/unzip"
+
+src_configure() {
+ USE_MD5="md5sum"
+ USE_FETCH="wget"
+ use openssl && USE_MD5="openssl"
+ use curl && USE_FETCH="curl"
+
+ # econf doesn't work b/c it passes variables the custom configure can't
+ # handle
+ ./configure \
+ --prefix=/usr \
+ --with-lua-lib=/usr/$(get_libdir) \
+ --rocks-tree=/usr/$(get_libdir)/lua/luarocks \
+ --with-downloader=$USE_FETCH \
+ --with-md5-checker=$USE_MD5 \
+ || die "configure failed"
+}
+
+src_compile() {
+ # -j1 b/c make tries to delete files it has yet to create (bug #402005)
+ emake DESTDIR="${D}" -j1 || die "make failed"
+}
+
+src_install() {
+ # -j1 b/c otherwise it fails to find src/bin/luarocks
+ emake DESTDIR="${D}" -j1 install || die "einstall"
+}
+
+pkg_preinst() {
+ find "${D}" -type f | xargs sed -i -e "s:${D}::g" || die "sed failed"
+}
diff --git a/dev-lua/luarocks/metadata.xml b/dev-lua/luarocks/metadata.xml
new file mode 100644
index 000000000000..e5711e37bd9f
--- /dev/null
+++ b/dev-lua/luarocks/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mabi@gentoo.org</email>
+ </maintainer>
+ <maintainer>
+ <email>rafaelmartins@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name='curl'>Uses <pkg>net-misc/curl</pkg> for fetching lua
+ packages instead of <pkg>net-misc/wget</pkg>.</flag>
+ <flag name='openssl'>Uses <pkg>dev-libs/openssl</pkg> for verifying lua
+ packages instead of md5sum.</flag>
+ </use>
+</pkgmetadata>