summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-12-01 13:15:10 +0100
committerConrad Kostecki <conikost@gentoo.org>2020-12-01 13:16:35 +0100
commitedcdfd8d8b3dd1c77b39dcd7db162cbeb3dafc71 (patch)
tree17be64dcae1b4f79920104a7bb91bd208f84285e /dev-lua/luarocks
parentsys-cluster/slurm: Drop old (diff)
downloadgentoo-edcdfd8d8b3dd1c77b39dcd7db162cbeb3dafc71.tar.gz
gentoo-edcdfd8d8b3dd1c77b39dcd7db162cbeb3dafc71.tar.bz2
gentoo-edcdfd8d8b3dd1c77b39dcd7db162cbeb3dafc71.zip
dev-lua/luarocks: patch LUA_LIBDIR check (non slotted)
If 'dev-lang/lua' is a new, fresh installation, no 'LUA_LIBDIR' exists, as no compiled modules are installed on a new, fresh installation, so this check must be disabled, otherwise 'configure' will fail. Closes: https://bugs.gentoo.org/757855 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/luarocks')
-rw-r--r--dev-lua/luarocks/luarocks-3.4.0.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/dev-lua/luarocks/luarocks-3.4.0.ebuild b/dev-lua/luarocks/luarocks-3.4.0.ebuild
index 1740df35645a..52063734ca52 100644
--- a/dev-lua/luarocks/luarocks-3.4.0.ebuild
+++ b/dev-lua/luarocks/luarocks-3.4.0.ebuild
@@ -37,6 +37,15 @@ BDEPEND="
)
"
+src_prepare() {
+ default
+
+ # If 'dev-lang/lua' is a new, fresh installation, no 'LUA_LIBDIR' exists,
+ # as no compiled modules are installed on a new, fresh installation,
+ # so this check must be disabled, otherwise 'configure' will fail.
+ sed -e '/LUA_LIBDIR is not a valid directory/d' -i configure || die
+}
+
src_configure() {
local myeconfargs=(
"--prefix=${EPREFIX}/usr"