summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-01-24 19:12:20 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-01-27 20:40:26 +0100
commit8e426ef2f798dccad5ae3140be21f3eb4cd6f56c (patch)
tree941628f54bc4198623cf4a389eb79a12ec257369 /dev-lua/luasocket
parentdev-lua/luasec: drop old version (diff)
downloadgentoo-8e426ef2f798dccad5ae3140be21f3eb4cd6f56c.tar.gz
gentoo-8e426ef2f798dccad5ae3140be21f3eb4cd6f56c.tar.bz2
gentoo-8e426ef2f798dccad5ae3140be21f3eb4cd6f56c.zip
dev-lua/luasocket: drop old version
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/luasocket')
-rw-r--r--dev-lua/luasocket/Manifest1
-rw-r--r--dev-lua/luasocket/files/proxy-fix.patch31
-rw-r--r--dev-lua/luasocket/luasocket-3.0_rc1-r5.ebuild58
-rw-r--r--dev-lua/luasocket/luasocket-3.0_rc1_p20200328-r1.ebuild72
4 files changed, 0 insertions, 162 deletions
diff --git a/dev-lua/luasocket/Manifest b/dev-lua/luasocket/Manifest
index ee78a7331866..8e11fe11f0a8 100644
--- a/dev-lua/luasocket/Manifest
+++ b/dev-lua/luasocket/Manifest
@@ -1,2 +1 @@
-DIST luasocket-3.0_rc1.tar.gz 328598 BLAKE2B 9cc382d909cfa018edec237ac901220cccb0cf0e3a775b9cd8083487ace42a94dfd280f9423097f677f37ee9f85afcfff844250cd49c0f813b7c50c3adc532c5 SHA512 f6efce259aaacaa11472911471f8a13b118fe009b8953a82c6aa18b9ec829cd1293180904e56935cb130d36d267e3f27c91db2d78e03f7488f3e100571ed0540
DIST luasocket-3.0_rc1_p20200328.tar.gz 335628 BLAKE2B 9e5d3e415337903b689705669b586c4481179a319b4e3428823c8f442d04f26db86bfeca66db7e58d157e31431c31e4f687403f7163b75f57d6f87cdb934717f SHA512 bdf7086a0504b0072b9cfd1266fc4ae89504053801722859a426f567fca00ed76f4c295c2a3a968e93f0036d9b792cf97561e9baa82c09ea23999cfd473227eb
diff --git a/dev-lua/luasocket/files/proxy-fix.patch b/dev-lua/luasocket/files/proxy-fix.patch
deleted file mode 100644
index 302e63663ff7..000000000000
--- a/dev-lua/luasocket/files/proxy-fix.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 1f9ccb2b586c3a7e29db3c99a23ac1cee6907cf2 Mon Sep 17 00:00:00 2001
-From: Pierre Chapuis <catwell@archlinux.us>
-Date: Fri, 5 Jul 2013 18:00:29 +0200
-Subject: [PATCH] http: look for PROXY in _M, not as a global
-
----
- src/http.lua | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/http.lua b/src/http.lua
-index 5f70a374..f83dcc55 100644
---- a/src/http.lua
-+++ b/src/http.lua
-@@ -186,7 +186,7 @@ end
- local function adjusturi(reqt)
- local u = reqt
- -- if there is a proxy, we need the full url. otherwise, just a part.
-- if not reqt.proxy and not PROXY then
-+ if not reqt.proxy and not _M.PROXY then
- u = {
- path = socket.try(reqt.path, "invalid path 'nil'"),
- params = reqt.params,
-@@ -198,7 +198,7 @@ local function adjusturi(reqt)
- end
-
- local function adjustproxy(reqt)
-- local proxy = reqt.proxy or PROXY
-+ local proxy = reqt.proxy or _M.PROXY
- if proxy then
- proxy = url.parse(proxy)
- return proxy.host, proxy.port or 3128
diff --git a/dev-lua/luasocket/luasocket-3.0_rc1-r5.ebuild b/dev-lua/luasocket/luasocket-3.0_rc1-r5.ebuild
deleted file mode 100644
index 8a12093b847f..000000000000
--- a/dev-lua/luasocket/luasocket-3.0_rc1-r5.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit multilib multilib-minimal flag-o-matic toolchain-funcs
-
-DESCRIPTION="Networking support library for the Lua language"
-HOMEPAGE="http://www.tecgraf.puc-rio.br/~diego/professional/luasocket/
- https://github.com/diegonehab/luasocket"
-SRC_URI="https://github.com/diegonehab/${PN}/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ~mips ppc ppc64 sparc x86"
-IUSE="debug"
-
-RDEPEND=">=dev-lang/lua-5.1.5-r2:0[${MULTILIB_USEDEP}]"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-S=${WORKDIR}/${PN}-${PV/_/-}
-
-RESTRICT="test"
-
-PATCHES=(
- "${FILESDIR}"/proxy-fix.patch
-)
-
-src_prepare() {
- default
- multilib_copy_sources
-}
-
-multilib_src_compile() {
- emake \
- CC="$(tc-getCC) ${CFLAGS}" \
- LD="$(tc-getCC) ${LDFLAGS}"\
- $(usex debug DEBUG="DEBUG" "")
-}
-
-multilib_src_install() {
- local luav=$($(tc-getPKG_CONFIG) --variable V lua)
- emake \
- DESTDIR="${D}" \
- LUAPREFIX_linux="${EPREFIX}/usr" \
- LUAV=${luav} \
- CDIR_linux=$(get_libdir)/lua/${luav} \
- install-unix
- insinto /usr/include/lua${luav}/luasocket
- doins src/*.h
-}
-
-multilib_src_install_all() {
- dodoc NEW README
- docinto html
- dodoc -r doc/.
-}
diff --git a/dev-lua/luasocket/luasocket-3.0_rc1_p20200328-r1.ebuild b/dev-lua/luasocket/luasocket-3.0_rc1_p20200328-r1.ebuild
deleted file mode 100644
index b05a982025b9..000000000000
--- a/dev-lua/luasocket/luasocket-3.0_rc1_p20200328-r1.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-EGIT_COMMIT="5b18e475f38fcf28429b1cc4b17baee3b9793a62"
-
-inherit flag-o-matic toolchain-funcs
-
-DESCRIPTION="Networking support library for the Lua language"
-HOMEPAGE="
- http://www.tecgraf.puc-rio.br/~diego/professional/luasocket/
- https://github.com/diegonehab/luasocket
-"
-SRC_URI="https://github.com/diegonehab/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE="luajit"
-RESTRICT="test"
-
-RDEPEND="
- luajit? ( dev-lang/luajit:2 )
- !luajit? ( dev-lang/lua:0 )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-HTML_DOCS="doc/."
-
-src_prepare() {
- default
-
- # Respect users CFLAGS
- sed -e 's/-O2 -ggdb3//g' -i src/makefile || die
-
- # Workaround for 32-bit systems
- append-cflags -fno-stack-protector
-}
-
-src_compile() {
- local myemakeargs=(
- "CC=$(tc-getCC)"
- "LD=$(tc-getCC)"
- "LDFLAGS_linux=-O -fpic -shared -o"
- "LUAINC_linux=$($(tc-getPKG_CONFIG) --variable includedir $(usex luajit 'luajit' 'lua'))"
- "LUAV=5.1"
- "MYCFLAGS=${CFLAGS}"
- "MYLDFLAGS=${LDFLAGS}"
- )
-
- emake "${myemakeargs[@]}" all
-}
-
-src_install() {
- local myemakeargs=(
- "CDIR=$($(tc-getPKG_CONFIG) --variable INSTALL_CMOD $(usex luajit 'luajit' 'lua'))"
- "DESTDIR=${ED}"
- "LDIR=$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD $(usex luajit 'luajit' 'lua'))"
- "LUAPREFIX_linux="
- )
-
- emake "${myemakeargs[@]}" install
- emake "${myemakeargs[@]}" install-unix
-
- insinto "$($(tc-getPKG_CONFIG) --variable includedir $(usex luajit 'luajit' 'lua'))/luasocket"
- doins src/*.h
-
- einstalldocs
-}