summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-11-29 16:34:38 +0100
committerConrad Kostecki <conikost@gentoo.org>2020-11-29 16:34:38 +0100
commitdf3228a18387762af34cc6f487583336abfff1d5 (patch)
treeeeddd8c869c563048b5de49eef86d6b0f227aa31 /dev-lua/luasocket
parentdev-lua/luafilesystem: drop old version (diff)
downloadgentoo-df3228a18387762af34cc6f487583336abfff1d5.tar.gz
gentoo-df3228a18387762af34cc6f487583336abfff1d5.tar.bz2
gentoo-df3228a18387762af34cc6f487583336abfff1d5.zip
dev-lua/luasocket: update ebuild
Updated ebuild not to use clean. Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/luasocket')
-rw-r--r--dev-lua/luasocket/luasocket-3.0_rc1_p20200328-r101.ebuild97
1 files changed, 97 insertions, 0 deletions
diff --git a/dev-lua/luasocket/luasocket-3.0_rc1_p20200328-r101.ebuild b/dev-lua/luasocket/luasocket-3.0_rc1_p20200328-r101.ebuild
new file mode 100644
index 000000000000..dab20430d3c6
--- /dev/null
+++ b/dev-lua/luasocket/luasocket-3.0_rc1_p20200328-r101.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_COMMIT="5b18e475f38fcf28429b1cc4b17baee3b9793a62"
+LUA_COMPAT=( lua5-{1..3} )
+LUA_REQ_USE="${MULTILIB_USEDEP}"
+MY_P="${PN}-${EGIT_COMMIT}"
+
+inherit flag-o-matic lua multilib-minimal toolchain-funcs
+
+DESCRIPTION="Networking support library for the Lua language"
+HOMEPAGE="
+ http://www.tecgraf.puc-rio.br/~diego/professional/luasocket/
+ https://github.com/diegonehab/luasocket
+"
+SRC_URI="https://github.com/diegonehab/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="test"
+
+RDEPEND="${LUA_DEPS}"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+HTML_DOCS="doc/."
+
+src_prepare() {
+ default
+
+ # Respect users CFLAGS
+ sed -e 's/-O2 -ggdb3//g' -i src/makefile || die
+
+ # Workaround for 32-bit systems
+ append-cflags -fno-stack-protector
+
+ lua_copy_sources
+ lua_foreach_impl multilib_copy_sources
+}
+
+lua_multilib_src_compile() {
+ pushd "${WORKDIR}/${MY_P}-${ELUA/./-}-${MULTILIB_ABI_FLAG}.${ABI}" || die
+
+ local myemakeargs=(
+ "CC=$(tc-getCC)"
+ "LD=$(tc-getCC)"
+ "LDFLAGS_linux=-O -fpic -shared -o"
+ "LUAINC_linux=$(lua_get_include_dir)"
+ "LUAV=${ELUA}"
+ "MIME_V=1.0.3-${ELUA}"
+ "MYCFLAGS=${CFLAGS}"
+ "MYLDFLAGS=${LDFLAGS}"
+ "SOCKET_V=3.0-rc1-${ELUA}"
+ )
+
+ emake "${myemakeargs[@]}" all
+
+ popd
+}
+
+multilib_src_compile() {
+ lua_foreach_impl lua_multilib_src_compile
+}
+
+lua_multilib_src_install() {
+ pushd "${WORKDIR}/${MY_P}-${ELUA/./-}-${MULTILIB_ABI_FLAG}.${ABI}" || die
+
+ local myemakeargs=(
+ "CDIR=$(lua_get_cmod_dir)"
+ "DESTDIR=${ED}"
+ "LDIR=$(lua_get_lmod_dir)"
+ "LUAPREFIX_linux="
+ "MIME_V=1.0.3-${ELUA}"
+ "SOCKET_V=3.0-rc1-${ELUA}"
+ )
+
+ emake "${myemakeargs[@]}" install
+ emake "${myemakeargs[@]}" install-unix
+
+ insinto "$(lua_get_include_dir)"/luasocket
+ doins src/*.h
+
+ popd
+}
+
+multilib_src_install() {
+ lua_foreach_impl lua_multilib_src_install
+}
+
+multilib_src_install_all() {
+ einstalldocs
+}