summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-11-28 18:21:16 +0100
committerConrad Kostecki <conikost@gentoo.org>2020-11-28 18:44:41 +0100
commit91f7497396a6b1d32759b57c758cc90db00526d0 (patch)
treebcdbbb713bce88d05496dcf4f4d0e26036fa60a2 /dev-lua/luassert
parentdev-lua/busted: drop old version (diff)
downloadgentoo-91f7497396a6b1d32759b57c758cc90db00526d0.tar.gz
gentoo-91f7497396a6b1d32759b57c758cc90db00526d0.tar.bz2
gentoo-91f7497396a6b1d32759b57c758cc90db00526d0.zip
dev-lua/luassert: fix lua deps
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/luassert')
-rw-r--r--dev-lua/luassert/luassert-1.8.0-r101.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-lua/luassert/luassert-1.8.0-r101.ebuild b/dev-lua/luassert/luassert-1.8.0-r101.ebuild
new file mode 100644
index 000000000000..a5902ef63a15
--- /dev/null
+++ b/dev-lua/luassert/luassert-1.8.0-r101.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..3} luajit )
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="Assertion library for Lua"
+HOMEPAGE="http://olivinelabs.com/busted/"
+SRC_URI="https://github.com/Olivine-Labs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-lua/say-1.3_p1-r100[${LUA_USEDEP}]
+ ${LUA_DEPS}
+"
+
+BDEPEND="
+ virtual/pkgconfig
+ test? (
+ >=dev-lua/busted-2.0.0-r100[${LUA_USEDEP}]
+ ${RDEPEND}
+ )
+"
+
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-1.8.0-disable-highlightcolor-test.patch" )
+
+lua_src_test() {
+ busted --lua=${ELUA} || die
+}
+
+src_test() {
+ lua_foreach_impl lua_src_test
+}
+
+lua_src_install() {
+ insinto $(lua_get_lmod_dir)/luassert
+ doins -r src/.
+
+ einstalldocs
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+}