summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 14:34:25 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 14:34:25 +0100
commit377e087aadffe4dc813f9e46128a0e915077ab29 (patch)
tree0be0c7e7134c994ebf4ec75c9181daf32f7d4cf7 /dev-lua/md5
parentdev-lua/md5: update EAPI 7 -> 8 (diff)
downloadgentoo-377e087aadffe4dc813f9e46128a0e915077ab29.tar.gz
gentoo-377e087aadffe4dc813f9e46128a0e915077ab29.tar.bz2
gentoo-377e087aadffe4dc813f9e46128a0e915077ab29.zip
dev-lua/md5: drop 1.3
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/md5')
-rw-r--r--dev-lua/md5/md5-1.3.ebuild85
1 files changed, 0 insertions, 85 deletions
diff --git a/dev-lua/md5/md5-1.3.ebuild b/dev-lua/md5/md5-1.3.ebuild
deleted file mode 100644
index 95caf85b7d2f..000000000000
--- a/dev-lua/md5/md5-1.3.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-LUA_COMPAT=( lua5-{1..4} luajit )
-
-inherit lua
-
-DESCRIPTION="Offers basic cryptographic facilities for Lua"
-HOMEPAGE="https://github.com/keplerproject/md5"
-SRC_URI="https://github.com/keplerproject/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-REQUIRED_USE="${LUA_REQUIRED_USE}"
-
-RDEPEND="${LUA_DEPS}"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- default
-
- lua_copy_sources
-}
-
-src_configure() {
- # Provided 'configure' script is useless.
- :;
-}
-
-lua_src_compile() {
- pushd "${BUILD_DIR}" || die
-
- local myemakeargs=(
- "CC=$(tc-getCC)"
- "CFLAGS=${CFLAGS} $(lua_get_CFLAGS) ${LDFLAGS}"
- )
-
- emake "${myemakeargs[@]}"
-
- popd
-}
-
-src_compile() {
- lua_foreach_impl lua_src_compile
-}
-
-lua_src_test() {
- pushd "${BUILD_DIR}/src" || die
-
- # Workaround for tests.
- ln -s core.so md5.so || die
-
- "${ELUA}" ../tests/test.lua
-
- popd
-}
-
-src_test() {
- lua_foreach_impl lua_src_test
-}
-
-lua_src_install() {
- pushd "${BUILD_DIR}" || die
-
- # Workaround, as 'Makefile' does not create this directory.
- dodir "$(lua_get_cmod_dir)"
-
- local myemakeargs=(
- "LUA_DIR=${ED}/$(lua_get_lmod_dir)"
- "LUA_LIBDIR=${ED}/$(lua_get_cmod_dir)"
- )
-
- emake "${myemakeargs[@]}" install
-
- popd
-}
-
-src_install() {
- lua_foreach_impl lua_src_install
-
- einstalldocs
-}