summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-11-28 16:49:13 +0100
committerConrad Kostecki <conikost@gentoo.org>2020-11-28 17:16:37 +0100
commit16fdc516b77abff5d254a7a452d206be51d8f52b (patch)
tree2b2f3e59dd8d48b39567f18bbd252c79f2bd2612 /dev-lua/mediator_lua
parentdev-lua/penlight: migrate to lua eclass (diff)
downloadgentoo-16fdc516b77abff5d254a7a452d206be51d8f52b.tar.gz
gentoo-16fdc516b77abff5d254a7a452d206be51d8f52b.tar.bz2
gentoo-16fdc516b77abff5d254a7a452d206be51d8f52b.zip
dev-lua/mediator_lua: migrate to lua eclass
Also adding tests. Bug: https://bugs.gentoo.org/628758 Closes: https://bugs.gentoo.org/752663 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/mediator_lua')
-rw-r--r--dev-lua/mediator_lua/mediator_lua-1.1.2_p0-r100.ebuild49
-rw-r--r--dev-lua/mediator_lua/metadata.xml6
2 files changed, 54 insertions, 1 deletions
diff --git a/dev-lua/mediator_lua/mediator_lua-1.1.2_p0-r100.ebuild b/dev-lua/mediator_lua/mediator_lua-1.1.2_p0-r100.ebuild
new file mode 100644
index 000000000000..69ece31e97a9
--- /dev/null
+++ b/dev-lua/mediator_lua/mediator_lua-1.1.2_p0-r100.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..3} luajit )
+MY_PV="${PV/_p/-}"
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="Mediator pattern implementation for pub-sub management "
+HOMEPAGE="http://olivinelabs.com/mediator_lua/"
+SRC_URI="https://github.com/Olivine-Labs/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="${LUA_DEPS}"
+BDEPEND="
+ virtual/pkgconfig
+ test? (
+ >=dev-lua/busted-2.0.0-r100
+ ${RDEPEND}
+ )
+"
+
+lua_src_test() {
+ busted --lua=${ELUA} || die
+}
+
+src_test() {
+ lua_foreach_impl lua_src_test
+}
+
+lua_src_install() {
+ insinto $(lua_get_lmod_dir)
+ doins src/mediator.lua
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+
+ einstalldocs
+}
diff --git a/dev-lua/mediator_lua/metadata.xml b/dev-lua/mediator_lua/metadata.xml
index 29d24e70698d..f38ef1ebf525 100644
--- a/dev-lua/mediator_lua/metadata.xml
+++ b/dev-lua/mediator_lua/metadata.xml
@@ -5,7 +5,11 @@
<email>williamh@gentoo.org</email>
<name>William Hubbs</name>
</maintainer>
- <longdescription lang="en">
+ <maintainer type="person">
+ <email>conikost@gentoo.org</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <longdescription>
mediator_lua allows you to subscribe and publish to a central object so
you can decouple function calls in your application. It's as simple as
mediator:subscribe("channel", function). Supports namespacing, predicates,