summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-03-19 15:38:48 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-03-19 16:21:21 +0100
commit388f78a76017df50151c4243c2b934da36eeca45 (patch)
treea71c54dd809fc011ffa337ed8581faed86a09bf9 /dev-lua/readline
parentapp-emulation/86Box: drop 3.2.1 (diff)
downloadgentoo-388f78a76017df50151c4243c2b934da36eeca45.tar.gz
gentoo-388f78a76017df50151c4243c2b934da36eeca45.tar.bz2
gentoo-388f78a76017df50151c4243c2b934da36eeca45.zip
dev-lua/readline: initial import
This is a needed dep for upcoming prosody-0.12 release. Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/readline')
-rw-r--r--dev-lua/readline/Manifest1
-rw-r--r--dev-lua/readline/metadata.xml8
-rw-r--r--dev-lua/readline/readline-3.0.ebuild93
3 files changed, 102 insertions, 0 deletions
diff --git a/dev-lua/readline/Manifest b/dev-lua/readline/Manifest
new file mode 100644
index 000000000000..1e2e13b8dfb3
--- /dev/null
+++ b/dev-lua/readline/Manifest
@@ -0,0 +1 @@
+DIST lua-readline-3.0.tar.gz 15675 BLAKE2B 877b50cdf05610eb54fcec6063368206d68b0571e70c28abd6bdf20e0533ae76809a18f3b7cbefc79185544966e2838c8ea95b30bc5821c31547026ee621d1f0 SHA512 7fc9b1b2b03909cd8ebccc539fa8c37a823c70728671dc09c7cec0641625a59ed3c8b7045635e53719d32046437e638193cb1055a94a3d635fb50efb199d213a
diff --git a/dev-lua/readline/metadata.xml b/dev-lua/readline/metadata.xml
new file mode 100644
index 000000000000..c07e13d4a6bd
--- /dev/null
+++ b/dev-lua/readline/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>conikost@gentoo.org</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-lua/readline/readline-3.0.ebuild b/dev-lua/readline/readline-3.0.ebuild
new file mode 100644
index 000000000000..6eb54114feba
--- /dev/null
+++ b/dev-lua/readline/readline-3.0.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="A simple interface to the readline and history libraries"
+HOMEPAGE="https://pjb.com.au/comp/lua/readline.html"
+SRC_URI="https://pjb.com.au/comp/lua/${P}.tar.gz -> lua-${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+# Tests are interactive
+RESTRICT="test"
+
+RDEPEND="
+ dev-lua/luaposix
+ sys-libs/readline
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ lua_copy_sources
+}
+
+lua_src_compile() {
+ pushd "${BUILD_DIR}" || die
+
+ local compiler=(
+ "$(tc-getCC)"
+ "${CFLAGS}"
+ "-fPIC"
+ "$(lua_get_CFLAGS)"
+ "-c C-readline.c"
+ "-o C-readline.o"
+ )
+ einfo "${compiler[@]}"
+ ${compiler[@]} || die
+
+ local linker=(
+ "$(tc-getCC)"
+ "-shared"
+ "${LDFLAGS}"
+ "$($(tc-getPKG_CONFIG) --libs readline)"
+ "-o C-readline.so"
+ "C-readline.o"
+ )
+ einfo "${linker[@]}"
+ ${linker[@]} || die
+
+ popd
+}
+
+src_compile() {
+ lua_foreach_impl lua_src_compile
+}
+
+lua_src_test() {
+ pushd "${BUILD_DIR}" || die
+ LUA_CPATH="./?.so;${EROOT}/usr/$(get_libdir)/lua/$(ver_cut 1-2 $(lua_get_version))/?.so" ${ELUA} test/test_rl.lua
+ popd
+}
+
+src_test() {
+ lua_foreach_impl lua_src_test
+}
+
+lua_src_install() {
+ pushd "${BUILD_DIR}" || die
+
+ insinto "$(lua_get_cmod_dir)"
+ doins C-readline.so
+
+ insinto "$(lua_get_lmod_dir)"
+ doins readline.lua
+
+ popd
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+
+ docinto html
+ dodoc doc/readline.html
+}