summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 21:39:19 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:55:55 +0100
commit0c40954c8a1827ef277e9008a91cf6b26addc46f (patch)
treedcffe9acec256e370cf946736bb747e188793e1d /dev-lua/say/say-1.3_p1-r1.ebuild
parentdev-lua/mpack: drop 1.0.8-r100, 1.0.9 (diff)
downloadgentoo-0c40954c8a1827ef277e9008a91cf6b26addc46f.tar.gz
gentoo-0c40954c8a1827ef277e9008a91cf6b26addc46f.tar.bz2
gentoo-0c40954c8a1827ef277e9008a91cf6b26addc46f.zip
dev-lua/say: update EAPI 7 -> 8
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/say/say-1.3_p1-r1.ebuild')
-rw-r--r--dev-lua/say/say-1.3_p1-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-lua/say/say-1.3_p1-r1.ebuild b/dev-lua/say/say-1.3_p1-r1.ebuild
new file mode 100644
index 000000000000..2ab1eba27b2c
--- /dev/null
+++ b/dev-lua/say/say-1.3_p1-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+MY_PV="${PV/_p/-}"
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="Lua String Hashing/Indexing Library"
+HOMEPAGE="http://olivinelabs.com/busted/"
+SRC_URI="https://github.com/Olivine-Labs/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~sparc x86"
+IUSE="test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="${LUA_DEPS}"
+
+BDEPEND="
+ virtual/pkgconfig
+ test? ( dev-lua/busted[${LUA_USEDEP}] )
+ ${RDEPEND}
+"
+
+lua_src_test() {
+ busted --lua=${ELUA} || die
+}
+
+src_test() {
+ lua_foreach_impl lua_src_test
+}
+
+lua_src_install() {
+ insinto $(lua_get_lmod_dir)/say
+ doins src/init.lua
+
+ einstalldocs
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+}