summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-lua/toluapp/toluapp-1.0.93.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-lua/toluapp/toluapp-1.0.93.ebuild')
-rw-r--r--dev-lua/toluapp/toluapp-1.0.93.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-lua/toluapp/toluapp-1.0.93.ebuild b/dev-lua/toluapp/toluapp-1.0.93.ebuild
new file mode 100644
index 000000000000..e1bfc370330c
--- /dev/null
+++ b/dev-lua/toluapp/toluapp-1.0.93.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+MY_P=${P/pp/++}
+
+DESCRIPTION="A tool to integrate C/C++ code with Lua"
+HOMEPAGE="http://www.codenix.com/~tolua/"
+SRC_URI="http://www.codenix.com/~tolua/${MY_P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/lua-5.1.1[deprecated]"
+DEPEND="${RDEPEND}
+ dev-util/scons"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ echo "## BEGIN gentoo.py
+
+LIBS = ['lua', 'dl', 'm']
+
+## END gentoo.py" > ${S}/custom.py
+
+ scons \
+ CC="$(tc-getCC)" \
+ CCFLAGS="${CFLAGS} -ansi -Wall" \
+ CXX="$(tc-getCXX)" \
+ LINK="$(tc-getCC)" \
+ LINKFLAGS="${LDFLAGS}" \
+ shared=1 || die "scons failed"
+}
+
+src_install() {
+ dobin bin/tolua++ || die "dobin failed"
+# dobin bin/tolua++_bootstrap || die "dobin failed"
+# dolib.a lib/libtolua++_static.a || die "dolib.a failed"
+ dolib.so lib/libtolua++.so || die "dolib.so failed"
+ insinto /usr/include
+ doins include/tolua++.h || die "doins failed"
+ dodoc README
+ dohtml doc/*
+}