summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2015-11-10 16:29:56 -0600
committerWilliam Hubbs <williamh@gentoo.org>2015-11-11 11:39:38 -0600
commitaca1d429c64399a4518df034fcabf58f6415873e (patch)
tree46276e1953aefc0c82fc9b3e1b67df7dc01cf91c /dev-lua
parentdev-lua/luassert: initial commit (diff)
downloadgentoo-aca1d429c64399a4518df034fcabf58f6415873e.tar.gz
gentoo-aca1d429c64399a4518df034fcabf58f6415873e.tar.bz2
gentoo-aca1d429c64399a4518df034fcabf58f6415873e.zip
dev-lua/mediator_lua: initial commit
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/mediator_lua/Manifest1
-rw-r--r--dev-lua/mediator_lua/mediator_lua-1.1.2_p0.ebuild33
-rw-r--r--dev-lua/mediator_lua/metadata.xml14
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-lua/mediator_lua/Manifest b/dev-lua/mediator_lua/Manifest
new file mode 100644
index 000000000000..ba29138772c7
--- /dev/null
+++ b/dev-lua/mediator_lua/Manifest
@@ -0,0 +1 @@
+DIST mediator_lua-1.1.2_p0.tar.gz 5809 SHA256 faf5859fd2081be4e9e4fb8873a2dc65f7eff3fd93d6dd14da65f8e123fcff9b SHA512 116d08a96fa0bd540ac4d3cac61a529a634cba3621c6f2e917b405462bbc0e2ab5b170dc6819e470105cdedf958a382945819eaff4affa63bc057824c163c8a0 WHIRLPOOL 0cc4951d53f1ebd4ef0d876e0a27a23319c8b4b64655b82d7eddc5f1488fd4bb0ed9eb583634e2c64692e19e1912f618aa41c29fb2c46e3ad594b4e3c77a287f
diff --git a/dev-lua/mediator_lua/mediator_lua-1.1.2_p0.ebuild b/dev-lua/mediator_lua/mediator_lua-1.1.2_p0.ebuild
new file mode 100644
index 000000000000..4743cce97d02
--- /dev/null
+++ b/dev-lua/mediator_lua/mediator_lua-1.1.2_p0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+# Below is the upstream version number. The"-0" suffix should be kept in
+# sync with the _p0 suffix of the ebuild version.
+MY_PV=1.1.2-0
+
+DESCRIPTION="Event handling through channels"
+HOMEPAGE="http://olivinelabs.com/mediator_lua/",
+SRC_URI="https://github.com/Olivine-Labs/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+COMMON_DEPEND=">=dev-lang/lua-5.1:="
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_install() {
+ insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)"
+ doins src/mediator.lua
+ dodoc README.md
+}
diff --git a/dev-lua/mediator_lua/metadata.xml b/dev-lua/mediator_lua/metadata.xml
new file mode 100644
index 000000000000..db26cdcbccbe
--- /dev/null
+++ b/dev-lua/mediator_lua/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+ <longdescription lang="en">
+ mediator_lua allows you to subscribe and publish to a central object so
+ you can decouple function calls in your application. It's as simple as
+ mediator:subscribe("channel", function). Supports namespacing, predicates,
+ and more.
+ </longdescription>
+</pkgmetadata>