summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-01 18:20:59 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-02 10:37:51 +0200
commitb9cae2b66f0d66355fe3b13c0889269551e2aa00 (patch)
tree317435500c2e15d20748449a02cc9bfaec71cd0e /dev-ml/async_extra
parentdev-ml/async_rpc_kernel: Bump to 0.9.0 (diff)
downloadgentoo-b9cae2b66f0d66355fe3b13c0889269551e2aa00.tar.gz
gentoo-b9cae2b66f0d66355fe3b13c0889269551e2aa00.tar.bz2
gentoo-b9cae2b66f0d66355fe3b13c0889269551e2aa00.zip
dev-ml/async_extra: Bump to 0.9.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ml/async_extra')
-rw-r--r--dev-ml/async_extra/Manifest2
-rw-r--r--dev-ml/async_extra/async_extra-0.9.0.ebuild32
-rw-r--r--dev-ml/async_extra/async_extra-113.33.03.ebuild54
3 files changed, 33 insertions, 55 deletions
diff --git a/dev-ml/async_extra/Manifest b/dev-ml/async_extra/Manifest
index e92ef7b386ca..75bc63a25032 100644
--- a/dev-ml/async_extra/Manifest
+++ b/dev-ml/async_extra/Manifest
@@ -1 +1 @@
-DIST async_extra-113.33.03.tar.gz 161678 SHA256 8e3cdcefe92272df99e8a79477032cfd9f7bc24dee2ce112d505f682e39328ea SHA512 4305d99e36e97545394ce3562b46aa285b1f1e69465bb075de20304150d856622a6c37606f4ce9db7f2828e5befc1356d4c3711ec9fc2afe1c1f865b92899ad6 WHIRLPOOL 9c8455aed548dfe95c292920489489e3ded0694f707d3fe3bfc9cd920938bd568c7636a5a395a15d775bc56fb39c614439452f85b070d7b7f9ca84dc1c6fde34
+DIST async_extra-0.9.0.tar.gz 105722 SHA256 473e3bdcd109cbf29b800776210c4ac9dad726b5a222d3c53b0610dd86804fa2 SHA512 6f0d69a389e66e47cd0a3cf288c2b0242299e5c3befa77f7a656bc30dfb63f78e5287c4de5e80473c1ce2ee5fed038bf0b4d2b94eb73f045b20f40b14868fa1a WHIRLPOOL fd7f0c447d58ff4e970cb818f49b3dcc4a62d372381907f6efca65e285ae01549527700e79a05448a8269f38663e961ee4af88420eacb3c0f90064dce0b83418
diff --git a/dev-ml/async_extra/async_extra-0.9.0.ebuild b/dev-ml/async_extra/async_extra-0.9.0.ebuild
new file mode 100644
index 000000000000..06c9100af230
--- /dev/null
+++ b/dev-ml/async_extra/async_extra-0.9.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Jane Street Capital's asynchronous execution library (extra)"
+HOMEPAGE="https://github.com/janestreet/async_extra"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=dev-lang/ocaml-4.02.0:=
+ dev-ml/async_kernel:=
+ dev-ml/async_rpc_kernel:=
+ dev-ml/async_unix:=
+ dev-ml/core:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_jane:=
+ dev-ml/ocaml-migrate-parsetree:=
+"
+DEPEND="${RDEPEND} dev-ml/opam dev-ml/jbuilder"
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+}
diff --git a/dev-ml/async_extra/async_extra-113.33.03.ebuild b/dev-ml/async_extra/async_extra-113.33.03.ebuild
deleted file mode 100644
index ccf14bb5bdff..000000000000
--- a/dev-ml/async_extra/async_extra-113.33.03.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-OASIS_BUILD_DOCS=1
-
-inherit oasis
-
-DESCRIPTION="Jane Street Capital's asynchronous execution library (extra)"
-HOMEPAGE="http://www.janestreet.com/ocaml"
-SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE=""
-
-RDEPEND=">=dev-lang/ocaml-4.02.0:=
- >=dev-ml/async_kernel-113.33:=
- >=dev-ml/async_rpc_kernel-113.33:=
- >=dev-ml/async_unix-113.33:=
- >=dev-ml/bin-prot-109.15.00:=
- >=dev-ml/core-113.33:=
- >=dev-ml/fieldslib-109.20.00:=
- dev-ml/ppx_assert:=
- dev-ml/ppx_bench:=
- dev-ml/ppx_driver:=
- dev-ml/ppx_expect:=
- dev-ml/ppx_inline_test:=
- dev-ml/ppx_jane:=
- >=dev-ml/sexplib-109.20.00:=
- dev-ml/typerep:=
- dev-ml/variantslib:=
-"
-DEPEND="${RDEPEND} dev-ml/opam"
-
-src_configure() {
- emake setup.exe
- OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
-}
-
-src_compile() {
- emake
-}
-
-src_install() {
- opam-installer -i \
- --prefix="${ED}/usr" \
- --libdir="${D}/$(ocamlc -where)" \
- --docdir="${ED}/usr/share/doc/${PF}" \
- ${PN}.install || die
- dodoc CHANGES.md
-}