summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-27 09:11:25 +0000
committerSam James <sam@gentoo.org>2021-01-27 09:12:04 +0000
commit340691fa679eb56df7a4aa45e5569af72fe986ff (patch)
treebe71a62514c328ba27f59fab208fa3b6480fef4e /dev-ml/async_ssl
parentdev-ml/async: bump to 0.14.0 (diff)
downloadgentoo-340691fa679eb56df7a4aa45e5569af72fe986ff.tar.gz
gentoo-340691fa679eb56df7a4aa45e5569af72fe986ff.tar.bz2
gentoo-340691fa679eb56df7a4aa45e5569af72fe986ff.zip
dev-ml/async_ssl: bump to 0.14.0
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/async_ssl')
-rw-r--r--dev-ml/async_ssl/Manifest1
-rw-r--r--dev-ml/async_ssl/async_ssl-0.14.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/async_ssl/Manifest b/dev-ml/async_ssl/Manifest
index 24567712360b..32fea853f7d3 100644
--- a/dev-ml/async_ssl/Manifest
+++ b/dev-ml/async_ssl/Manifest
@@ -1,2 +1,3 @@
+DIST async_ssl-0.14.0.tar.gz 40338 BLAKE2B eb673f30d7374b539b37c84ba88e0daf8eeeacc93b278a44177a433cb8b336a843cc05e6033ec8ee831ec1c28fc243c8019a82bd495e96a1e54dfd47a3d10b13 SHA512 89397d0066444cbfdd3d4d27942ff04b3adbe2a9cf11427795fcf59127908c94f88c1575f395aa74eee49abb5be2e86940a88945dda6435fb81165bd58b789a7
DIST async_ssl-0.9.0.tar.gz 28227 BLAKE2B e916e196964d085312836d773e290ac52c950c5ceb084347557d72776c7b6b9548ad2bd01c5fc6fa701d18c55fff62e48af5459bf5897478252f8d27dd6687fc SHA512 bb023e0c60f9f04368f2e2a4aea80700a60853a03fe1550fe48a9defe42ec66736a6cc0cf40c6a472cd3f8b5b30d79711e4fd714b53ebd4ba7f3f3c22eb7a15e
DIST async_ssl-0.9.1.tar.gz 28162 BLAKE2B 74987fcad26dcb641687e044ef76531cfa88e2bb62524d0eddf5ce3fe4f4dc9c7b07f13de63e9cdddd4a5db2e7e20f2a7f3a8543b17678a342e2890ed816189a SHA512 5e20d3c2a46e81d725076a80347047de90d00d6a0956457656ffd629d80b7a65958fd8a831d407dd11e3a3583662ed1e04242e71580ab7e982dc579ee69bface
diff --git a/dev-ml/async_ssl/async_ssl-0.14.0.ebuild b/dev-ml/async_ssl/async_ssl-0.14.0.ebuild
new file mode 100644
index 000000000000..fba5e18f5769
--- /dev/null
+++ b/dev-ml/async_ssl/async_ssl-0.14.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="An Async-pipe-based interface with OpenSSL."
+HOMEPAGE="https://github.com/janestreet/async_ssl"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ dev-lang/ocaml:=
+ dev-ml/async:=
+ dev-ml/base:=
+ dev-ml/core:=
+ dev-ml/dune-configurator:=
+ dev-ml/ppx_jane:=
+ dev-ml/stdio:=
+ dev-ml/ocaml-ctypes:=
+ dev-libs/openssl:0=
+"
+DEPEND="${RDEPEND}"