summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-01 18:16:35 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-02 10:37:50 +0200
commit123586db39d9c4323f6963d22999113275229682 (patch)
treee9eefe8a520fa1bb6fe44059f105ad02e7adad07 /dev-ml/async_unix
parentdev-ml/async_kernel: Bump to 0.9.0 (diff)
downloadgentoo-123586db39d9c4323f6963d22999113275229682.tar.gz
gentoo-123586db39d9c4323f6963d22999113275229682.tar.bz2
gentoo-123586db39d9c4323f6963d22999113275229682.zip
dev-ml/async_unix: Bump to 0.9.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ml/async_unix')
-rw-r--r--dev-ml/async_unix/Manifest2
-rw-r--r--dev-ml/async_unix/async_unix-0.9.0.ebuild31
-rw-r--r--dev-ml/async_unix/async_unix-113.33.00.ebuild58
3 files changed, 32 insertions, 59 deletions
diff --git a/dev-ml/async_unix/Manifest b/dev-ml/async_unix/Manifest
index 67c22da968bc..af80a66df814 100644
--- a/dev-ml/async_unix/Manifest
+++ b/dev-ml/async_unix/Manifest
@@ -1 +1 @@
-DIST async_unix-113.33.00.tar.gz 195062 SHA256 ebffb3c4341e57d4f7cb347d387b9ccbd46c46f1ebd5db0c7782cdf3237fa9ec SHA512 15ed26ba51efda3f07c1bca3e0935290ed99accaa61cb60f7460e72624944d3edb3454c2ddb29deaf9928b4d4c1332c3035cd0c8d4e2dceb3a947b0ff8ee944c WHIRLPOOL 159276f4eaccc2ba36378fc0b206ea3e4fc35a28d599786504f416fa1d70f3a42965065ac9d63e82e9e5d87481da6a6cea913953a486e790289c625f059de9ad
+DIST async_unix-0.9.0.tar.gz 156717 SHA256 ca5bad7ec53207772ff9eee6bccedd9a11ec51d8a274e8c86ce7feab43be3bd8 SHA512 cd3fb43ffcde8fe01386a0460beb52e2530786dc0abce318c5241243e123ebd57fbf4cff8c91300483f33ae5dc1c0cc591992dc55286dc6ec550be62afb33b42 WHIRLPOOL 3aad07ad6862b93c0ce2ba92a712ebc6bfad10ec74e6f9fb03a1868efb5980123bf1d70ccf033e5868f95d1230b51472b387c5e8f045bd5f17591c1bd978f901
diff --git a/dev-ml/async_unix/async_unix-0.9.0.ebuild b/dev-ml/async_unix/async_unix-0.9.0.ebuild
new file mode 100644
index 000000000000..98434a7fab88
--- /dev/null
+++ b/dev-ml/async_unix/async_unix-0.9.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Jane Street Capital's asynchronous execution library (unix)"
+HOMEPAGE="https://github.com/janestreet/async_unix"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ >=dev-lang/ocaml-4.02.0:=
+ dev-ml/async_kernel:=
+ dev-ml/core:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_jane:=
+ dev-ml/ocaml-migrate-parsetree:=
+"
+DEPEND="${RDEPEND} dev-ml/opam dev-ml/jbuilder"
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+}
diff --git a/dev-ml/async_unix/async_unix-113.33.00.ebuild b/dev-ml/async_unix/async_unix-113.33.00.ebuild
deleted file mode 100644
index 0d7d9a3064de..000000000000
--- a/dev-ml/async_unix/async_unix-113.33.00.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-OASIS_BUILD_DOCS=1
-
-inherit oasis
-
-DESCRIPTION="Jane Street Capital's asynchronous execution library (unix)"
-HOMEPAGE="http://www.janestreet.com/ocaml"
-SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE=""
-
-RDEPEND="
- >=dev-lang/ocaml-4.02.0:=
- dev-ml/async_kernel:=
- dev-ml/bin-prot:=
- dev-ml/ocaml-ctypes:=
- >=dev-ml/fieldslib-109.20.00:=
- dev-ml/ppx_assert:=
- dev-ml/ppx_bench:=
- dev-ml/ppx_driver:=
- dev-ml/ppx_expect:=
- dev-ml/ppx_inline_test:=
- dev-ml/ppx_jane:=
- >=dev-ml/sexplib-109.20.00:=
- dev-ml/typerep:=
- dev-ml/variantslib:=
- dev-ml/core:=
-"
-DEPEND="${RDEPEND} dev-ml/opam"
-
-src_prepare() {
- has_version '>=dev-lang/ocaml-4.03' && epatch "${FILESDIR}/oc43.patch"
-}
-
-src_configure() {
- emake setup.exe
- OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
-}
-
-src_compile() {
- emake
-}
-
-src_install() {
- opam-installer -i \
- --prefix="${ED}/usr" \
- --libdir="${D}/$(ocamlc -where)" \
- --docdir="${ED}/usr/share/doc/${PF}" \
- ${PN}.install || die
- dodoc CHANGES.md
-}