summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-07-15 16:45:04 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-07-15 16:45:12 +0200
commita6232326ea8d9c04aaa3863e15a8edc5745f282a (patch)
tree112bd9e233e595be6766200cfaa435ee47079d0f /dev-ml/biniou/biniou-1.1.0.ebuild
parentkde-frameworks/kpackage: keyword ~arm64 (diff)
downloadgentoo-a6232326ea8d9c04aaa3863e15a8edc5745f282a.tar.gz
gentoo-a6232326ea8d9c04aaa3863e15a8edc5745f282a.tar.bz2
gentoo-a6232326ea8d9c04aaa3863e15a8edc5745f282a.zip
dev-ml/biniou: bump to 1.1.0
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ml/biniou/biniou-1.1.0.ebuild')
-rw-r--r--dev-ml/biniou/biniou-1.1.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ml/biniou/biniou-1.1.0.ebuild b/dev-ml/biniou/biniou-1.1.0.ebuild
new file mode 100644
index 000000000000..6a9705355a2a
--- /dev/null
+++ b/dev-ml/biniou/biniou-1.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="A binary data serialization format inspired by JSON for OCaml"
+HOMEPAGE="https://github.com/mjambon/biniou"
+SRC_URI="https://github.com/mjambon/biniou/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0/${PV}"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-3.11:=[ocamlopt?]
+ dev-ml/easy-format:=[ocamlopt?]
+"
+DEPEND="${RDEPEND}
+ dev-ml/jbuilder
+ dev-ml/opam
+"
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ --mandir="${ED}/usr/share/man" \
+ ${PN}.install || die
+}