summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ml/camldbm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ml/camldbm')
-rw-r--r--dev-ml/camldbm/Manifest1
-rw-r--r--dev-ml/camldbm/camldbm-1.0.ebuild29
-rw-r--r--dev-ml/camldbm/files/hasgotfix.patch15
-rw-r--r--dev-ml/camldbm/files/include_fix.patch15
-rw-r--r--dev-ml/camldbm/metadata.xml5
5 files changed, 65 insertions, 0 deletions
diff --git a/dev-ml/camldbm/Manifest b/dev-ml/camldbm/Manifest
new file mode 100644
index 000000000000..ed1f28b1ac0a
--- /dev/null
+++ b/dev-ml/camldbm/Manifest
@@ -0,0 +1 @@
+DIST camldbm-1.0.tgz 14397 SHA256 19741fa7827c306ae43b18170b01f5547326ec7ea6c2f4bd80c93439b5ff538f SHA512 d0b752754650efb400f13f957e83fddccf1fc9ac9e1d11f453af94e9aa599546a316eb110685b3728b593c99cbf859cdc7bcf924c878cf8b6dead3dc413ccfbf WHIRLPOOL 44b1489614d55520569020e205f069263d58f5a2101cebe8c8f4f7bf40fa9db5d16afe64fe4fb729104b9774b1609cc342946fd07914b3d2059892211fe776ec
diff --git a/dev-ml/camldbm/camldbm-1.0.ebuild b/dev-ml/camldbm/camldbm-1.0.ebuild
new file mode 100644
index 000000000000..f6205c74a27c
--- /dev/null
+++ b/dev-ml/camldbm/camldbm-1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit base
+
+DESCRIPTION="OCaml binding to the NDBM/GDBM Unix databases"
+HOMEPAGE="http://forge.ocamlcore.org/projects/camldbm/"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/728/${P}.tgz"
+
+LICENSE="LGPL-2-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+DEPEND="|| ( >=sys-libs/gdbm-1.9.1-r2[berkdb] <sys-libs/gdbm-1.9.1-r2 )
+ >=dev-lang/ocaml-3.12:=[ocamlopt]
+ !<dev-lang/ocaml-4[gdbm]"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/hasgotfix.patch" "${FILESDIR}/include_fix.patch" )
+
+src_install() {
+ dodir "$(ocamlc -where)/stublibs" # required and makefile does not create it
+ emake LIBDIR="${D}/$(ocamlc -where)" install
+ dodoc README Changelog
+}
diff --git a/dev-ml/camldbm/files/hasgotfix.patch b/dev-ml/camldbm/files/hasgotfix.patch
new file mode 100644
index 000000000000..840ffcbe7f0f
--- /dev/null
+++ b/dev-ml/camldbm/files/hasgotfix.patch
@@ -0,0 +1,15 @@
+https://forge.ocamlcore.org/tracker/index.php?func=detail&aid=1202&group_id=278&atid=1189
+
+Index: camldbm-1.0/configure
+===================================================================
+--- camldbm-1.0.orig/configure
++++ camldbm-1.0/configure
+@@ -35,7 +35,7 @@ hasgot() {
+ ${CC:-cc} -I$1 -o hasgot.exe hasgot.c $3 $4
+ res=$?
+ rm -f hasgot.c hasgot.exe
+- return $?
++ return $res
+ }
+
+ dbm_include="not found"
diff --git a/dev-ml/camldbm/files/include_fix.patch b/dev-ml/camldbm/files/include_fix.patch
new file mode 100644
index 000000000000..16fb6bd1e96e
--- /dev/null
+++ b/dev-ml/camldbm/files/include_fix.patch
@@ -0,0 +1,15 @@
+https://forge.ocamlcore.org/tracker/index.php?func=detail&aid=1201&group_id=278&atid=1189
+
+Index: camldbm-1.0/Makefile
+===================================================================
+--- camldbm-1.0.orig/Makefile
++++ camldbm-1.0/Makefile
+@@ -51,7 +51,7 @@ libcamldbm.$(A): cldbm.$(O)
+ $(OCAMLOPT) -c $(COMPFLAGS) $<
+
+ .c.$(O):
+- $(OCAMLC) -c -ccopt "$(DBM_INCLUDE)" -ccopt "$(DBM_DEFINES)" $<
++ $(OCAMLC) -c -ccopt "$(DBM_INCLUDES)" -ccopt "$(DBM_DEFINES)" $<
+
+ depend:
+ $(OCAMLDEP) *.ml *.mli > .depend
diff --git a/dev-ml/camldbm/metadata.xml b/dev-ml/camldbm/metadata.xml
new file mode 100644
index 000000000000..2193d772e351
--- /dev/null
+++ b/dev-ml/camldbm/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+</pkgmetadata>