summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-03-03 12:23:47 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-03-03 12:28:43 +0100
commita66d6e2380344b539ecf299531bd5e9254fb71f3 (patch)
tree2ff9e66af437cfa01ddd211b54205d935d84fb5b /dev-ml/camlp4/camlp4-4.05_p1.ebuild
parentprofiles/package.mask: mask camlp4-4.05 for ocaml 4.05 (diff)
downloadgentoo-a66d6e2380344b539ecf299531bd5e9254fb71f3.tar.gz
gentoo-a66d6e2380344b539ecf299531bd5e9254fb71f3.tar.bz2
gentoo-a66d6e2380344b539ecf299531bd5e9254fb71f3.zip
dev-ml/camlp4: bump to 4.05
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-ml/camlp4/camlp4-4.05_p1.ebuild')
-rw-r--r--dev-ml/camlp4/camlp4-4.05_p1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-ml/camlp4/camlp4-4.05_p1.ebuild b/dev-ml/camlp4/camlp4-4.05_p1.ebuild
new file mode 100644
index 000000000000..f2382e86d203
--- /dev/null
+++ b/dev-ml/camlp4/camlp4-4.05_p1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MY_PV=${PV/_p/+}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="System for writing extensible parsers for programming languages"
+HOMEPAGE="https://github.com/ocaml/camlp4"
+SRC_URI="https://github.com/ocaml/camlp4/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="+ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-4.05_beta:=[ocamlopt?]"
+RDEPEND="${DEPEND}
+ !<dev-lang/ocaml-4.02
+ !<dev-ml/findlib-1.5.5-r1"
+DEPEND="${DEPEND}
+ dev-ml/ocamlbuild"
+
+S=${WORKDIR}/${P/_p/-}
+
+src_configure() {
+ ./configure \
+ --bindir="${EPREFIX}/usr/bin" \
+ --libdir="$(ocamlc -where)" \
+ --pkgdir="$(ocamlc -where)" \
+ || die
+}
+
+src_compile() {
+ emake byte
+ use ocamlopt && emake native
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-META
+ dodoc CHANGES.md README.md
+}