summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2020-10-13 16:01:27 +1100
committerMark Wright <gienah@gentoo.org>2020-10-13 23:53:21 +1100
commit95fce53afd61cf621a450182528b4fe4f0637fe6 (patch)
treec5cc2a19db7a47c85db0676f5afb89bed7c75adc /dev-ml/camlp4
parentdev-ml/camlbz2: EAPI=7 (diff)
downloadgentoo-95fce53afd61cf621a450182528b4fe4f0637fe6.tar.gz
gentoo-95fce53afd61cf621a450182528b4fe4f0637fe6.tar.bz2
gentoo-95fce53afd61cf621a450182528b4fe4f0637fe6.zip
dev-ml/camlp4: Bump to 4.11_p1
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Mark Wright <gienah@gentoo.org>
Diffstat (limited to 'dev-ml/camlp4')
-rw-r--r--dev-ml/camlp4/Manifest2
-rw-r--r--dev-ml/camlp4/camlp4-4.10_p1.ebuild46
-rw-r--r--dev-ml/camlp4/camlp4-4.11_p1.ebuild46
-rw-r--r--dev-ml/camlp4/metadata.xml11
4 files changed, 101 insertions, 4 deletions
diff --git a/dev-ml/camlp4/Manifest b/dev-ml/camlp4/Manifest
index cc8bcfc4f3e0..5a0713d643b4 100644
--- a/dev-ml/camlp4/Manifest
+++ b/dev-ml/camlp4/Manifest
@@ -1,3 +1,5 @@
DIST camlp4-4.04_p1.tar.gz 648320 BLAKE2B d383a366facaaa440b24184bb54a8e1c3bb22ae02387a0bc4f9ee4331ecdc60e5bf22715c1022c987041fb081eb448794a74026736df9f70e05c7213e08bfa44 SHA512 7db8eebcf3d230f60650ba62d9cb630c069394237e97b678a40b61d3dcaded752a2b7e089a50ff528f1ea0740d0291b722df123a072f2cee489cadc5201c6776
DIST camlp4-4.05_p1.tar.gz 647566 BLAKE2B 068c1016a75616811787eb480b61349a32960997f03e0bc99d63e15357a8932a6019d9e7195541fd942ef99fc1d71c067fb5fcb0fd0c2c3efb77aac494589854 SHA512 0ee9720286d0d832fb7d2d21a8877856e0e47c94c86b1b58d28f8e757a18472eecb56a16e3a04ce815f240dd5048f5d597515461d084fd1cf4da1b121f97a3fe
DIST camlp4-4.08_p1.tar.gz 649830 BLAKE2B 8dff6f82618d0f61a56acfa71ae679d4ba5ed4aea272019da7b19ea64960c80e50c55482ff9782748dad5042aa1bcd8728ff0825f8f900ff27239db0e0db3515 SHA512 1f8d6df42935ecdbed96a7b02d05564665b4bf0cbe4f5fd1800a1f292d8b3864d973df1e9e8c566c0fd00b5a55ba47ecd9bd07f134a9be83601e010b0246e075
+DIST camlp4-4.10_p1.tar.gz 650092 BLAKE2B d7a6221dba5f6ec6963fe35236c29f39b8ae8f928618b5a58f72e7b1cc1f50d716b110f9684150716b56784cf703c0d8fcbc1aad32aeab638faca9c1bf2d5b9e SHA512 7ae0e20053a43399daa4ee9b93b6f4dbebc3e17c5ee79d069c4903cdfb2bf1cfc7d6badecf92fcf62e97a5f85f3be6ed82a62eb2a311bf6398b2792eacf763d8
+DIST camlp4-4.11_p1.tar.gz 650280 BLAKE2B 6fe46b49c1f2b2e5fc87fbbbdba3ccae795c555737495c298456b84f0dca79c750aa6e4ab2c23bbc7ba4724defdfb739e370f468a78658035474d2f3ad255995 SHA512 8e572602c1c465017a234565efa2249c935ba1ad3d399a6b264bfbec345958130a96311c79e437ac995e3ead9ff7b4f2d3fe6aa4a3a82431ae0cc6257a300f4c
diff --git a/dev-ml/camlp4/camlp4-4.10_p1.ebuild b/dev-ml/camlp4/camlp4-4.10_p1.ebuild
new file mode 100644
index 000000000000..e3b30a5018b3
--- /dev/null
+++ b/dev-ml/camlp4/camlp4-4.10_p1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV=${PV/_p/+}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="System for writing extensible parsers for programming languages"
+HOMEPAGE="https://github.com/camlp4/camlp4"
+SRC_URI="https://github.com/camlp4/camlp4/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-4.10.0:=[ocamlopt?]"
+RDEPEND="${DEPEND}
+ !<dev-lang/ocaml-4.02
+ !<dev-ml/findlib-1.5.5-r1"
+DEPEND="${DEPEND}
+ dev-ml/ocamlbuild"
+
+S=${WORKDIR}/${P/_p/-}
+PATCHES=( "${FILESDIR}/reload.patch" )
+
+src_configure() {
+ ./configure \
+ --bindir="${EPREFIX}/usr/bin" \
+ --libdir="$(ocamlc -where)" \
+ --pkgdir="$(ocamlc -where)" \
+ || die
+}
+
+src_compile() {
+ # Increase stack limit to 11GiB to avoid stack overflow error.
+ ulimit -s 11530000
+ emake byte
+ use ocamlopt && emake native
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-META
+ dodoc CHANGES.md README.md
+}
diff --git a/dev-ml/camlp4/camlp4-4.11_p1.ebuild b/dev-ml/camlp4/camlp4-4.11_p1.ebuild
new file mode 100644
index 000000000000..35aeda06b933
--- /dev/null
+++ b/dev-ml/camlp4/camlp4-4.11_p1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV=${PV/_p/+}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="System for writing extensible parsers for programming languages"
+HOMEPAGE="https://github.com/camlp4/camlp4"
+SRC_URI="https://github.com/camlp4/camlp4/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-4.11.0:=[ocamlopt?]"
+RDEPEND="${DEPEND}
+ !<dev-lang/ocaml-4.02
+ !<dev-ml/findlib-1.5.5-r1"
+DEPEND="${DEPEND}
+ dev-ml/ocamlbuild"
+
+S=${WORKDIR}/${P/_p/-}
+PATCHES=( "${FILESDIR}/reload.patch" )
+
+src_configure() {
+ ./configure \
+ --bindir="${EPREFIX}/usr/bin" \
+ --libdir="$(ocamlc -where)" \
+ --pkgdir="$(ocamlc -where)" \
+ || die
+}
+
+src_compile() {
+ # Increase stack limit to 11GiB to avoid stack overflow error.
+ ulimit -s 11530000
+ emake byte
+ use ocamlopt && emake native
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-META
+ dodoc CHANGES.md README.md
+}
diff --git a/dev-ml/camlp4/metadata.xml b/dev-ml/camlp4/metadata.xml
index 33d51779cb3d..2578754c2469 100644
--- a/dev-ml/camlp4/metadata.xml
+++ b/dev-ml/camlp4/metadata.xml
@@ -1,8 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
- <upstream>
- <remote-id type="github">camlp4/camlp4</remote-id>
- </upstream>
+ <maintainer type="person">
+ <email>gienah@gentoo.org</email>
+ <name>Mark Wright</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">camlp4/camlp4</remote-id>
+ </upstream>
</pkgmetadata>