summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-12-27 11:41:56 -0700
committerTim Harder <radhermit@gentoo.org>2019-12-27 12:10:31 -0700
commit8ab404de9c1c3a1e9e34dfeef8d937c61de3707a (patch)
tree0317a96d38ef501c7febbd6ca842091720f46a13 /dev-ml/camlpdf
parentdev-erlang/pkix: Version bump (diff)
downloadgentoo-8ab404de9c1c3a1e9e34dfeef8d937c61de3707a.tar.gz
gentoo-8ab404de9c1c3a1e9e34dfeef8d937c61de3707a.tar.bz2
gentoo-8ab404de9c1c3a1e9e34dfeef8d937c61de3707a.zip
dev-ml/camlpdf: version bump to 2.3.1
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'dev-ml/camlpdf')
-rw-r--r--dev-ml/camlpdf/Manifest1
-rw-r--r--dev-ml/camlpdf/camlpdf-2.3.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-ml/camlpdf/Manifest b/dev-ml/camlpdf/Manifest
index a716415d257f..5f78b11d7bb5 100644
--- a/dev-ml/camlpdf/Manifest
+++ b/dev-ml/camlpdf/Manifest
@@ -1,2 +1,3 @@
DIST camlpdf-2.2.1.tar.gz 570782 BLAKE2B 218dc3f0de67eebd983a849769372daa5630b1c5b4f488f4eeb1c73defc8da76ce65c73e43dc6fed5474f78aa01331a93e83ae6289aa099d71e30cd6c13f0777 SHA512 7539294434479b529edb7b46017f324b98bc0b83d25c1254a52ab1b67f8e3e04c2b8709ba22c6a0ac5e4444c65ef37e4645a495ea3ee011d3e95cd3021d559c2
+DIST camlpdf-2.3.1.tar.gz 601531 BLAKE2B 9534baf9165e7dc48ae37a3fcaabb236e437845ef4e0a60a1c08874a2b240c9b1e96de5bbd6028a3ca87992221773dea34c31b0fa24e9c143632756954baf132 SHA512 0b8d91b6090221f996aee52f22f153a4b74cb85a127bbd5f84492ede8a0a581971a2349281b3879d6c37f4d5d267da583e7e8871372d97a3d636abc3231cb007
DIST camlpdf-2.3.tar.gz 601250 BLAKE2B 9b2a7f6a90d33a69d3a6c15c4c299e7fde4633a78cbd43e1b779f713d371ee16dc588449e024e35a83cef8c24d7059844c92f3354391381437bea37595b604a7 SHA512 dfb81692f894f071bb32634e371cdb202af17f671fb1b9c379ff3d360453a0909c3b6d9960aae45cac49e20f06aeb49ad6db276324542e7be306831ef586d255
diff --git a/dev-ml/camlpdf/camlpdf-2.3.1.ebuild b/dev-ml/camlpdf/camlpdf-2.3.1.ebuild
new file mode 100644
index 000000000000..965e0ef70c14
--- /dev/null
+++ b/dev-ml/camlpdf/camlpdf-2.3.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib
+
+DESCRIPTION="OCaml library for reading, writing, and modifying PDF files"
+HOMEPAGE="https://github.com/johnwhitington/camlpdf/"
+SRC_URI="https://github.com/johnwhitington/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+# technically LGPL-2.1+ with linking exception
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="dev-lang/ocaml:=[ocamlopt]"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ # parallel make bugs
+ emake -j1
+}
+
+src_install() {
+ findlib_src_install
+ dodoc Changes README.md
+
+ if use doc ; then
+ dodoc introduction_to_camlpdf.pdf
+ dodoc -r doc/camlpdf/html
+ fi
+
+ use examples && dodoc -r examples
+}