summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-06 01:53:59 +0100
committerSam James <sam@gentoo.org>2021-10-06 02:01:00 +0100
commit15644176b54aadf106ddd2e9e765fe554da56e58 (patch)
tree922a7c9440af216f50f93308abbbb3d73c669c36 /dev-ml/camlzip
parentdev-ml/core_kernel: add 0.14.2 (diff)
downloadgentoo-15644176b54aadf106ddd2e9e765fe554da56e58.tar.gz
gentoo-15644176b54aadf106ddd2e9e765fe554da56e58.tar.bz2
gentoo-15644176b54aadf106ddd2e9e765fe554da56e58.zip
dev-ml/camlzip: add 1.11
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/camlzip')
-rw-r--r--dev-ml/camlzip/Manifest1
-rw-r--r--dev-ml/camlzip/camlzip-1.11.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-ml/camlzip/Manifest b/dev-ml/camlzip/Manifest
index 2cb16e028b34..d6e4ea7f08f8 100644
--- a/dev-ml/camlzip/Manifest
+++ b/dev-ml/camlzip/Manifest
@@ -1 +1,2 @@
DIST camlzip-1.10.tar.gz 27335 BLAKE2B bbf24953634278589395dd9fcedf1e3becce8dad1f380393dc3ac59589143e1685dc14085ef566e12fb751c6f1a333dd368795a5083b94a43b71e058e86489f3 SHA512 5c42e0d808230e3820b2e7ef34b544ca51a7bf0a484ce4e1c8b1e4966133196bb3ff7c3ca85b9c50050aca389316eb52f0335f6e2ad60c000594a33171b9a9a9
+DIST camlzip-1.11.tar.gz 28483 BLAKE2B b270e2a764547117d87a18f9ccca82891bc0dce182ea84f76b693acb34488ff25d8975154b843787554798bfd34c16dc6a25c431f8674c8c59eb2c195167c12b SHA512 4d69ef900437e66e00cd345497ec70f407f28cd8344ee5f2fad685d3bfe356924597d1854b752f2841b4007f96d6e0307cfae7e13cfb6f74951ae3eba5198a06
diff --git a/dev-ml/camlzip/camlzip-1.11.ebuild b/dev-ml/camlzip/camlzip-1.11.ebuild
new file mode 100644
index 000000000000..09d1e837bb67
--- /dev/null
+++ b/dev-ml/camlzip/camlzip-1.11.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib
+
+DESCRIPTION="Compressed file access ML library (ZIP, GZIP and JAR)"
+HOMEPAGE="https://github.com/xavierleroy/camlzip"
+SRC_URI="https://github.com/xavierleroy/camlzip/archive/rel$(ver_rs 1- '').tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-rel$(ver_rs 1- '')"
+
+LICENSE="LGPL-2.1"
+SLOT="1/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-4.07:=[ocamlopt?]
+ >=sys-libs/zlib-1.1.3"
+DEPEND="${RDEPEND}"
+
+QA_FLAGS_IGNORED=(
+ "usr/lib.*/ocaml/stublibs/dllcamlzip.so"
+ "usr/lib.*/ocaml/zip/zip.cmxs"
+)
+
+src_compile() {
+ emake all
+
+ if use ocamlopt; then
+ emake allopt
+ fi
+}
+
+src_install() {
+ findlib_src_preinst
+
+ emake DESTDIR="${D}" install-findlib
+ dosym zip/libcamlzip.a /usr/$(get_libdir)/ocaml/libcamlzip.a
+
+ dodoc README.md Changes
+}