summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-08-11 10:51:15 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-08-15 07:36:57 +0200
commitbc12043d8ff7ca62c1c93e28feb664377e32071c (patch)
treef8fc4a8e5e7811a9021ac8fd7e7b3e22ddf90f41 /dev-ml/capnp-ocaml
parentdev-ml/stringext: bump to 1.5.0 (diff)
downloadgentoo-bc12043d8ff7ca62c1c93e28feb664377e32071c.tar.gz
gentoo-bc12043d8ff7ca62c1c93e28feb664377e32071c.tar.bz2
gentoo-bc12043d8ff7ca62c1c93e28feb664377e32071c.zip
dev-ml/capnp-ocaml: bump to 3.0.0
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-ml/capnp-ocaml')
-rw-r--r--dev-ml/capnp-ocaml/Manifest1
-rw-r--r--dev-ml/capnp-ocaml/capnp-ocaml-3.0.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/capnp-ocaml/Manifest b/dev-ml/capnp-ocaml/Manifest
index c751b113fede..306b87f25b91 100644
--- a/dev-ml/capnp-ocaml/Manifest
+++ b/dev-ml/capnp-ocaml/Manifest
@@ -1 +1,2 @@
DIST capnp-ocaml-2.1.1.tar.gz 189731 SHA256 b4718b650c51ba05292afcbd1cb0ddfbd3efc7e160c65736538434b76c9cd931 SHA512 79083c2f387d6055a2cab45230b97f579a727418d55be13d3ca0135efd8561787b772012ed7f6f3277f9a34df3cb4684242bd754e048fbe77e4c8ba8ff9faf93 WHIRLPOOL c7b697cc8a2e2d26900a2845140d302da8b81aa5cdd8cfc0fd1ff95b8193b3f51185e7da3275b76582d98a7b03808c21e7eafb98d55e3d9ac700aac0ac614f68
+DIST capnp-ocaml-3.0.0.tar.gz 140985 SHA256 01b5380d4d4ec5392c91036787d93a553055ad403ff41d2cf73caff25a9098cc SHA512 5cdf678fa80e67c552f60123f1d04eb5facad81e6c29661c2234c06bbcb98312d1eba96f81f3e747fef0b4de986aff07b69aafcbfde60873ba40452a66d75075 WHIRLPOOL 2b6f04034c81dd0d01089b3ff39c681dab98a665ade944ca5d21014bb2d61b5bcaa4e4545e65d2829e9a837b44423cca580e7c6ca87a62d55c33e81caf859e3e
diff --git a/dev-ml/capnp-ocaml/capnp-ocaml-3.0.0.ebuild b/dev-ml/capnp-ocaml/capnp-ocaml-3.0.0.ebuild
new file mode 100644
index 000000000000..7820e1bd3298
--- /dev/null
+++ b/dev-ml/capnp-ocaml/capnp-ocaml-3.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit opam
+
+DESCRIPTION="OCaml code generator plugin for the Cap'n Proto serialization framework"
+HOMEPAGE="https://github.com/pelzlpj/capnp-ocaml"
+SRC_URI="https://github.com/pelzlpj/capnp-ocaml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-ml/core_kernel:=
+ dev-ml/ocaml-extunix:=
+ dev-ml/ocplib-endian:=
+ dev-ml/res:=
+ dev-ml/ocaml-uint:=
+ dev-libs/capnproto:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/core:= dev-ml/ounit )
+ dev-ml/jbuilder
+"
+
+src_install() {
+ opam_src_install capnp
+}