summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-01 19:13:59 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-02 10:38:01 +0200
commiteaade94eb1e80eb9f563563bafc3c9807ffc3e6d (patch)
treea09ce55d02906515fa93ea3a16d18f0936513136 /dev-ml/core_profiler/core_profiler-0.9.0.ebuild
parentdev-ml/bignum: Bump to 0.9.0 (diff)
downloadgentoo-eaade94eb1e80eb9f563563bafc3c9807ffc3e6d.tar.gz
gentoo-eaade94eb1e80eb9f563563bafc3c9807ffc3e6d.tar.bz2
gentoo-eaade94eb1e80eb9f563563bafc3c9807ffc3e6d.zip
dev-ml/core_profiler: Bump to 0.9.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ml/core_profiler/core_profiler-0.9.0.ebuild')
-rw-r--r--dev-ml/core_profiler/core_profiler-0.9.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/core_profiler/core_profiler-0.9.0.ebuild b/dev-ml/core_profiler/core_profiler-0.9.0.ebuild
new file mode 100644
index 000000000000..bf5b496ea736
--- /dev/null
+++ b/dev-ml/core_profiler/core_profiler-0.9.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Jane Street's profiling library"
+HOMEPAGE="https://github.com/janestreet/core_profiler"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-lang/ocaml:=
+ dev-ml/core:=
+ dev-ml/core_extended:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_jane:=
+ dev-ml/re2:=
+ dev-ml/textutils:=
+ dev-ml/ocaml-migrate-parsetree:=
+ "
+DEPEND="${RDEPEND} dev-ml/opam dev-ml/jbuilder"
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+}