summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-08-19 16:51:45 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-08-19 16:51:50 +0200
commita2c7e842f1a2321a1ddc09c4b2a4c775425a8e22 (patch)
tree73e87ddb7129e97dc176b6fb042f45f02aa0b2c2 /dev-ml/cppo/cppo-1.4.0.ebuild
parentdev-ml/pomap: bump to 3.0.6 (diff)
downloadgentoo-a2c7e842f1a2321a1ddc09c4b2a4c775425a8e22.tar.gz
gentoo-a2c7e842f1a2321a1ddc09c4b2a4c775425a8e22.tar.bz2
gentoo-a2c7e842f1a2321a1ddc09c4b2a4c775425a8e22.zip
dev-ml/cppo: bump to 1.4.0
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ml/cppo/cppo-1.4.0.ebuild')
-rw-r--r--dev-ml/cppo/cppo-1.4.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ml/cppo/cppo-1.4.0.ebuild b/dev-ml/cppo/cppo-1.4.0.ebuild
new file mode 100644
index 000000000000..dd063e75c6b3
--- /dev/null
+++ b/dev-ml/cppo/cppo-1.4.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit findlib
+
+DESCRIPTION="An equivalent of the C preprocessor for OCaml programs"
+HOMEPAGE="http://mjambon.com/cppo.html"
+SRC_URI="https://github.com/mjambon/cppo/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0/${PV}"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+
+IUSE="examples"
+
+RDEPEND=">=dev-lang/ocaml-3.12:=
+ dev-ml/ocamlbuild:="
+DEPEND="${RDEPEND}"
+
+src_install() {
+ findlib_src_preinst
+ mkdir -p "${ED}"/usr/bin
+ emake PREFIX="${ED}"/usr install
+ dodoc README.md Changes
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}