summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-12 16:08:12 +0000
committerSam James <sam@gentoo.org>2021-03-13 15:15:29 +0000
commit81a6e40e15a7539970514e8e775d476616ae7909 (patch)
tree2703711ec96ff460e64924b38a6f3480e2ef8ae7 /dev-ml/cryptokit
parentsci-geosciences/viking: fix build with USE=libexif (diff)
downloadgentoo-81a6e40e15a7539970514e8e775d476616ae7909.tar.gz
gentoo-81a6e40e15a7539970514e8e775d476616ae7909.tar.bz2
gentoo-81a6e40e15a7539970514e8e775d476616ae7909.zip
dev-ml/cryptokit: drop 1.10, 1.11 (oasis.eclass)
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/cryptokit')
-rw-r--r--dev-ml/cryptokit/Manifest2
-rw-r--r--dev-ml/cryptokit/cryptokit-1.10.ebuild48
-rw-r--r--dev-ml/cryptokit/cryptokit-1.11.ebuild50
3 files changed, 0 insertions, 100 deletions
diff --git a/dev-ml/cryptokit/Manifest b/dev-ml/cryptokit/Manifest
index 5130ec3c26b4..9c7817ee97ca 100644
--- a/dev-ml/cryptokit/Manifest
+++ b/dev-ml/cryptokit/Manifest
@@ -1,3 +1 @@
-DIST cryptokit-1.10.tar.gz 152525 BLAKE2B 51c905757ad141292be89707bdab5c83a1f3e9e2665202cbf17e12b115591c57b77b759b4fa2967d1f00b4cf5bd87445a2189b4d222d5d1613e19c32e1054189 SHA512 22564e0151c492963d75fb81780b3a884a0bf613ad09380d9b5365740fd9c4bbdaa1c21fed50a1a4934dce920d90f5c86dc014f90e52677544789311f7bded4f
-DIST cryptokit-1.11.tar.gz 156905 BLAKE2B 3fc77321c0d525a32f5733d77963b5df4e618b3168f2f00aceeb1e13b16cc202e79b50afa93c0769f016b4e43061ff19851c8ba3f40ad7f8f0c9ff78a51d68e7 SHA512 cc641a05a67cd3d2e5ec481e8d426796db625ab60e89f79bde2e360730892c62f30ea2e37c4b028df16471220847e6d7ce4984deb9528fec6647a17fc4ae1b0d
DIST cryptokit-1.16.1.tar.gz 120607 BLAKE2B fbb89c4dabef8f09614003acc2b8173fdfdacb36793fd20f4415ebec04f3759537739eccd7b9d143df0163816b9db65c221c2b83408c9ac3aa7f9bf7b63876c6 SHA512 28913a7c35ae951a4c464287acc511ee1bdc9d03b5928e2243c5ae5cbb8b10afe8e84d7a73ba6478ed62657d01fdb6f02472739255c33de3671c4130b659da52
diff --git a/dev-ml/cryptokit/cryptokit-1.10.ebuild b/dev-ml/cryptokit/cryptokit-1.10.ebuild
deleted file mode 100644
index 59e05f0f84ed..000000000000
--- a/dev-ml/cryptokit/cryptokit-1.10.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-OASIS_BUILD_DOCS=1
-OASIS_BUILD_TESTS=1
-
-inherit oasis
-
-DESCRIPTION="Cryptographic primitives library for Objective Caml"
-HOMEPAGE="http://forge.ocamlcore.org/projects/cryptokit/"
-SRC_URI="http://forge.ocamlcore.org/frs/download.php/1493/${P}.tar.gz"
-LICENSE="LGPL-2"
-SLOT="0/${PV}"
-KEYWORDS="amd64 ppc x86"
-IUSE="zlib"
-
-DEPEND="zlib? ( >=sys-libs/zlib-1.1 )"
-RDEPEND="${DEPEND}"
-
-DOCS=( "Changes" "README.txt" "AUTHORS.txt" )
-
-src_configure() {
- oasis_configure_opts="$(use_enable zlib)" \
- oasis_src_configure
-}
-
-pkg_postinst() {
- elog ""
- elog "This library uses the /dev/random device to generate "
- elog "random data and RSA keys. The device should either be"
- elog "built into the kernel or provided as a module. An"
- elog "alternative is to use the Entropy Gathering Daemon"
- elog "(http://egd.sourceforge.net). Please note that the"
- elog "remainder of the library will still work even in the"
- elog "absence of a one of these sources of randomness."
- elog ""
-}
-
-src_test() {
- echo ""
- einfo "You must have either /dev/random or the Entropy Gathering"
- einfo "Daemon (EGD) for this test to succeed!"
- echo ""
-
- oasis_src_test
-}
diff --git a/dev-ml/cryptokit/cryptokit-1.11.ebuild b/dev-ml/cryptokit/cryptokit-1.11.ebuild
deleted file mode 100644
index 152ab71573fc..000000000000
--- a/dev-ml/cryptokit/cryptokit-1.11.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-OASIS_BUILD_DOCS=1
-OASIS_BUILD_TESTS=1
-
-inherit oasis
-
-DESCRIPTION="Cryptographic primitives library for Objective Caml"
-HOMEPAGE="http://forge.ocamlcore.org/projects/cryptokit/"
-SRC_URI="http://forge.ocamlcore.org/frs/download.php/1618/${P}.tar.gz"
-LICENSE="LGPL-2"
-SLOT="0/${PV}"
-KEYWORDS="amd64 ppc x86"
-IUSE="zlib"
-
-DEPEND="zlib? ( >=sys-libs/zlib-1.1 )
- dev-ml/zarith:="
-RDEPEND="${DEPEND}"
-
-DOCS=( "Changes" "README.txt" "AUTHORS.txt" )
-REQUIRED_USE="test? ( ocamlopt )"
-
-src_configure() {
- oasis_configure_opts="$(use_enable zlib)" \
- oasis_src_configure
-}
-
-pkg_postinst() {
- elog ""
- elog "This library uses the /dev/random device to generate "
- elog "random data and RSA keys. The device should either be"
- elog "built into the kernel or provided as a module. An"
- elog "alternative is to use the Entropy Gathering Daemon"
- elog "(http://egd.sourceforge.net). Please note that the"
- elog "remainder of the library will still work even in the"
- elog "absence of a one of these sources of randomness."
- elog ""
-}
-
-src_test() {
- echo ""
- einfo "You must have either /dev/random or the Entropy Gathering"
- einfo "Daemon (EGD) for this test to succeed!"
- echo ""
-
- oasis_src_test
-}