summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-27 14:10:13 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-27 14:48:28 +0100
commit8163bfa18bbf6807d6f7ef01eff9ffb7b8989781 (patch)
treeed9ac89bd1f49b3352829df33f798fc77e746d13 /dev-ml/csv/csv-1.6.ebuild
parentdev-util/drone: Add new snapshot (diff)
downloadgentoo-8163bfa18bbf6807d6f7ef01eff9ffb7b8989781.tar.gz
gentoo-8163bfa18bbf6807d6f7ef01eff9ffb7b8989781.tar.bz2
gentoo-8163bfa18bbf6807d6f7ef01eff9ffb7b8989781.zip
dev-ml/csv: Bump to 1.6
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ml/csv/csv-1.6.ebuild')
-rw-r--r--dev-ml/csv/csv-1.6.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/csv/csv-1.6.ebuild b/dev-ml/csv/csv-1.6.ebuild
new file mode 100644
index 000000000000..a725347d62e1
--- /dev/null
+++ b/dev-ml/csv/csv-1.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="A pure OCaml library to read and write CSV files"
+HOMEPAGE="https://github.com/Chris00/ocaml-csv"
+SRC_URI="https://github.com/Chris00/ocaml-csv/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+lwt"
+
+DEPEND="lwt? ( dev-ml/lwt:= )"
+RDEPEND="${DEPEND}"
+
+DOCS=( "README.txt" "AUTHORS.txt" )
+
+src_configure() {
+ oasis_configure_opts="$(use_enable lwt)" \
+ oasis_src_configure
+}