summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-06-20 11:50:38 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-06-20 14:11:49 +0200
commit672d93e305b4e3ffca71c55b5749177ff353b806 (patch)
tree0f0e02850c6383529f5a4e6d18f64c8a242ff40d /dev-ml/csv/csv-1.7.ebuild
parentdev-python/pysnmp: Version bump. (diff)
downloadgentoo-672d93e305b4e3ffca71c55b5749177ff353b806.tar.gz
gentoo-672d93e305b4e3ffca71c55b5749177ff353b806.tar.bz2
gentoo-672d93e305b4e3ffca71c55b5749177ff353b806.zip
dev-ml/csv: Bump to 1.7
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ml/csv/csv-1.7.ebuild')
-rw-r--r--dev-ml/csv/csv-1.7.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ml/csv/csv-1.7.ebuild b/dev-ml/csv/csv-1.7.ebuild
new file mode 100644
index 000000000000..817e095edb27
--- /dev/null
+++ b/dev-ml/csv/csv-1.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="A pure OCaml library to read and write CSV files"
+HOMEPAGE="https://github.com/Chris00/ocaml-csv"
+SRC_URI="https://github.com/Chris00/ocaml-csv/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+lwt"
+
+DEPEND="lwt? ( dev-ml/lwt:= )"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ dev-ml/oasis"
+
+DOCS=( "README.txt" "AUTHORS.txt" )
+
+S="${WORKDIR}/ocaml-${P}"
+
+src_prepare() {
+ default
+ oasis setup || die
+}
+
+src_configure() {
+ oasis_configure_opts="$(use_enable lwt)" \
+ oasis_src_configure
+}