summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2021-12-11 03:40:30 +0100
committerMaciej Barć <xgqt@gentoo.org>2021-12-11 03:57:04 +0100
commit68c11d2c6e2d6b34d7999f1046864f030569beb0 (patch)
tree0892cae740bc8c75dcb0113eacf8bd88b175a1b4 /dev-ml/dune-build-info/dune-build-info-2.9.1.ebuild
parentdev-ml/dune-site: new package; add version 2.9.1 (diff)
downloadgentoo-68c11d2c6e2d6b34d7999f1046864f030569beb0.tar.gz
gentoo-68c11d2c6e2d6b34d7999f1046864f030569beb0.tar.bz2
gentoo-68c11d2c6e2d6b34d7999f1046864f030569beb0.zip
dev-ml/dune-build-info: new package; add version 2.9.1
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-ml/dune-build-info/dune-build-info-2.9.1.ebuild')
-rw-r--r--dev-ml/dune-build-info/dune-build-info-2.9.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ml/dune-build-info/dune-build-info-2.9.1.ebuild b/dev-ml/dune-build-info/dune-build-info-2.9.1.ebuild
new file mode 100644
index 000000000000..c23cca94315a
--- /dev/null
+++ b/dev-ml/dune-build-info/dune-build-info-2.9.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Embed locations informations inside executable and libraries"
+HOMEPAGE="https://github.com/ocaml/dune"
+SRC_URI="https://github.com/ocaml/dune/archive/${PV}.tar.gz -> dune-${PV}.tar.gz"
+S="${WORKDIR}/dune-${PV}"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt"
+RESTRICT="test"
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ dune build -p ${PN} @install || die
+}