summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-04 02:35:17 +0000
committerSam James <sam@gentoo.org>2021-04-04 06:09:34 +0000
commitd444e2246543a152c9065074ca9a547c52508a9f (patch)
tree275a0adb307adbfc6b2fc8c24f95c5e1a30af77f /dev-ml/gsl-ocaml
parentdev-ml/core_extended: treeclean (diff)
downloadgentoo-d444e2246543a152c9065074ca9a547c52508a9f.tar.gz
gentoo-d444e2246543a152c9065074ca9a547c52508a9f.tar.bz2
gentoo-d444e2246543a152c9065074ca9a547c52508a9f.zip
dev-ml/gsl-ocaml: add 1.19.1 (Dune port)
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/gsl-ocaml')
-rw-r--r--dev-ml/gsl-ocaml/Manifest1
-rw-r--r--dev-ml/gsl-ocaml/gsl-ocaml-1.24.3.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/gsl-ocaml/Manifest b/dev-ml/gsl-ocaml/Manifest
index f544670afdc0..173d01fffc5a 100644
--- a/dev-ml/gsl-ocaml/Manifest
+++ b/dev-ml/gsl-ocaml/Manifest
@@ -1 +1,2 @@
+DIST gsl-1.24.3.tbz 100642 BLAKE2B cf1bd63593901ba41ec33a8d073d923351e8cd6021f0402ce337242dd6b378408e740f2904a1c53f123453444dc08a05971921ab53e683b2ecf1e8a869f28e46 SHA512 c6e2578618591d1bef428693b69026cdea0f1606cd25d9f02d637a90256a5685eee70ecd0259d2595a1cd7b292c34e3c913c007e2706aa125af045d37e55d9c4
DIST gsl-ocaml-1.19.1.tar.gz 167549 BLAKE2B 17d559b31a2be9583fd616b273f1d5cac5a42bebc7df2cf4882ba5bf7ddf411971b4f49dc36eb3bcdb0265ea204d0ea0ba19bc6c63f49a6b8b6075715bd0a967 SHA512 be199d46479f07a16d2f667d7a29675171bc4ecc5a6e5948335bf98f72e6f12474d16455a22e6bfc73683f1d67de3a186d75f817f398f6621241b640c333e07d
diff --git a/dev-ml/gsl-ocaml/gsl-ocaml-1.24.3.ebuild b/dev-ml/gsl-ocaml/gsl-ocaml-1.24.3.ebuild
new file mode 100644
index 000000000000..7de5ef50474e
--- /dev/null
+++ b/dev-ml/gsl-ocaml/gsl-ocaml-1.24.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DUNE_PKG_NAME="gsl"
+inherit dune
+
+MY_P=${P/-ocaml/}
+DESCRIPTION="OCaml bindings for the GSL library (successor of dev-ml/ocamlgsl)"
+HOMEPAGE="https://github.com/mmottl/gsl-ocaml"
+SRC_URI="https://github.com/mmottl/${PN}/releases/download/${PV}/${MY_P}.tbz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-ml/dune-configurator
+ >=sci-libs/gsl-1.19
+"
+RDEPEND="${DEPEND}
+ !dev-ml/ocamlgsl"
+
+# DOCS=( CHANGES.txt README.md NOTES.md TODO.md )