summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-21 17:46:09 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-22 11:28:08 +0200
commit296e41e6d05bc7177f328abcbe90ecbf4e5b642e (patch)
tree9cc88040ef9f5aa8d0ce64a7965f1ec86e4e7417 /dev-ml/llvm-ocaml
parentapp-text/pdf2djvu: Remove mistaken use of PYTHON_REQUIRED_USE (diff)
downloadgentoo-296e41e6d05bc7177f328abcbe90ecbf4e5b642e.tar.gz
gentoo-296e41e6d05bc7177f328abcbe90ecbf4e5b642e.tar.bz2
gentoo-296e41e6d05bc7177f328abcbe90ecbf4e5b642e.zip
dev-ml/llvm-ocaml: Remove mistaken use of PYTHON_REQUIRED_USE
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-ml/llvm-ocaml')
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-10.0.0.9999.ebuild3
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-5.0.2.ebuild5
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-6.0.1.ebuild5
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-7.1.0.ebuild3
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-8.0.0.ebuild3
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-8.0.1.ebuild3
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-9.0.0.9999.ebuild3
7 files changed, 9 insertions, 16 deletions
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-10.0.0.9999.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-10.0.0.9999.ebuild
index a1c107a504b3..e354e4765340 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-10.0.0.9999.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-10.0.0.9999.ebuild
@@ -43,8 +43,7 @@ DEPEND="${RDEPEND}
!!<dev-python/configparser-3.3.0.2
${PYTHON_DEPS}"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}
- || ( ${ALL_LLVM_TARGETS[*]} )"
+REQUIRED_USE="|| ( ${ALL_LLVM_TARGETS[*]} )"
# least intrusive of all
CMAKE_BUILD_TYPE=RelWithDebInfo
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-5.0.2.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-5.0.2.ebuild
index ca74c5a91283..d21c45f2aac3 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-5.0.2.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-5.0.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -39,8 +39,7 @@ DEPEND="${RDEPEND}
!!<dev-python/configparser-3.3.0.2
${PYTHON_DEPS}"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}
- || ( ${ALL_LLVM_TARGETS[*]} )"
+REQUIRED_USE="|| ( ${ALL_LLVM_TARGETS[*]} )"
S=${WORKDIR}/${MY_P}
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-6.0.1.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-6.0.1.ebuild
index 0e64a225bb7b..8973393dd2af 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-6.0.1.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-6.0.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -40,8 +40,7 @@ DEPEND="${RDEPEND}
!!<dev-python/configparser-3.3.0.2
${PYTHON_DEPS}"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}
- || ( ${ALL_LLVM_TARGETS[*]} )"
+REQUIRED_USE="|| ( ${ALL_LLVM_TARGETS[*]} )"
S=${WORKDIR}/${MY_P}
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-7.1.0.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-7.1.0.ebuild
index 844cf32241cb..8973393dd2af 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-7.1.0.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-7.1.0.ebuild
@@ -40,8 +40,7 @@ DEPEND="${RDEPEND}
!!<dev-python/configparser-3.3.0.2
${PYTHON_DEPS}"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}
- || ( ${ALL_LLVM_TARGETS[*]} )"
+REQUIRED_USE="|| ( ${ALL_LLVM_TARGETS[*]} )"
S=${WORKDIR}/${MY_P}
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-8.0.0.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-8.0.0.ebuild
index f083d7d40b80..1604aeb371f4 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-8.0.0.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-8.0.0.ebuild
@@ -40,8 +40,7 @@ DEPEND="${RDEPEND}
!!<dev-python/configparser-3.3.0.2
${PYTHON_DEPS}"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}
- || ( ${ALL_LLVM_TARGETS[*]} )"
+REQUIRED_USE="|| ( ${ALL_LLVM_TARGETS[*]} )"
S=${WORKDIR}/${MY_P}
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-8.0.1.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-8.0.1.ebuild
index 6281e463ee69..154f485d0514 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-8.0.1.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-8.0.1.ebuild
@@ -40,8 +40,7 @@ DEPEND="${RDEPEND}
!!<dev-python/configparser-3.3.0.2
${PYTHON_DEPS}"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}
- || ( ${ALL_LLVM_TARGETS[*]} )"
+REQUIRED_USE="|| ( ${ALL_LLVM_TARGETS[*]} )"
S=${WORKDIR}/${MY_P}
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-9.0.0.9999.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-9.0.0.9999.ebuild
index 16e3da238954..28e3cb65696c 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-9.0.0.9999.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-9.0.0.9999.ebuild
@@ -42,8 +42,7 @@ DEPEND="${RDEPEND}
!!<dev-python/configparser-3.3.0.2
${PYTHON_DEPS}"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}
- || ( ${ALL_LLVM_TARGETS[*]} )"
+REQUIRED_USE="|| ( ${ALL_LLVM_TARGETS[*]} )"
# least intrusive of all
CMAKE_BUILD_TYPE=RelWithDebInfo